Project

General

Profile

Bug #7097

Error starting apache on SLES11 relay

Added by Alexis MOUSSET over 5 years ago. Updated over 5 years ago.

Status:
Released
Priority:
N/A
Assignee:
Matthieu CERDA
Category:
System integration
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

nds/'/sbin/service apache2 start'[0]: Finished command related to promiser '/sbin/service apache2 start' -- an error occurred, returned 1
2015-08-12T15:18:43+0200   notice: /default/root_component_check/methods/'any'/default/generic_process_check_process/methods/'start_process'/default/service_ensure_running_path/methods/'start if not running'/default/service_start/methods/'start'/default/service_action/methods/'action'/default/command_execution/commands/'/sbin/service apache2 start'[0]: Q: "...in/service apac": Starting httpd2 (prefork) Warning: DocumentRoot [/var/www] does not exist
Q: "...in/service apac": Syntax error on line 10 of /etc/apache2/vhosts.d/rudder-relay-vhost.conf:
Q: "...in/service apac": Invalid command '<IfVersion', perhaps misspelled or defined by a module not included in the server configuration
Q: "...in/service apac": The command line was:
Q: "...in/service apac": /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
Q: "...in/service apac": ..failed

Related issues

Related to Rudder - Bug #6836: Relay configuration should be defined on httpsReleasedMatthieu CERDA2015-07-01Actions
#1

Updated by Alexis MOUSSET over 5 years ago

works after running a2enmod version

#2

Updated by Alexis MOUSSET over 5 years ago

This has been fixed for 3.1 in #6836.

#3

Updated by Alexis MOUSSET over 5 years ago

  • Status changed from New to In progress
  • Assignee set to Alexis MOUSSET
#4

Updated by Alexis MOUSSET over 5 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Alexis MOUSSET to Matthieu CERDA
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/736
#5

Updated by Jonathan CLARKE over 5 years ago

Alexis, when you find a related ticket, as you mentioned in comment #2 above, please add it using Redmine's "Related issues" section above. This makes it visible also from the other ticket and has proved very useful over time.

I've fixed this one for you, but please remember this in the future.

#6

Updated by Jonathan CLARKE over 5 years ago

  • Related to Bug #6836: Relay configuration should be defined on https added
#7

Updated by Alexis MOUSSET over 5 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100
#8

Updated by Matthieu CERDA over 5 years ago

#9

Updated by Vincent MEMBRÉ over 5 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 3.0.9 and 3.1.2 which were released today.

Also available in: Atom PDF