Project

General

Profile

Bug #7119

Wrong reporting in rpmPackageInstallation when trying to update a non-existent package

Added by Alexis MOUSSET over 3 years ago. Updated 29 days ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Techniques
Target version:
Pull Request:
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
0

Description

R: @@packageInstallation@@result_success@@32377fd7-02fd-43d0-aab7-28460a91347b@@d09e0623-7b6d-4ff4-81be-22eeea82d795@@9@@RHEL/CentOS/SuSE packages@@somepackage@@2015-08-19 13:29:54+00:00##root@#No action required for RPM package somepackage with policy: update

or even sometimes:

R: @@packageInstallation@@result_error@@32377fd7-02fd-43d0-aab7-28460a91347b@@d09e0623-7b6d-4ff4-81be-22eeea82d795@@7@@RHEL/CentOS/SuSE packages@@somepackage@@2015-08-19 13:22:53+00:00##root@#Error taking action for RPM package somepackage with policy: update
R: @@packageInstallation@@result_success@@32377fd7-02fd-43d0-aab7-28460a91347b@@d09e0623-7b6d-4ff4-81be-22eeea82d795@@7@@RHEL/CentOS/SuSE packages@@somepackage@@2015-08-19 13:22:53+00:00##root@#No action required for RPM package somepackage with policy: update

Related issues

Related to Rudder - Bug #7116: Issue updating RPM using "Package management for RHEL / CentOS / SuSE / RPM systems"Rejected2015-08-19
Related to Rudder - Bug #3040: Package management for RHEL / CentOS / SuSE / RPM systems : Reporting about installation is wrong when a package is not available or met dependencies problemRejected2012-11-27
Related to Rudder - User story #8230: Package management issues in Rudder/ncfRejected

History

#1 Updated by Alexis MOUSSET over 3 years ago

  • Related to Bug #7116: Issue updating RPM using "Package management for RHEL / CentOS / SuSE / RPM systems" added

#2 Updated by Alexis MOUSSET over 3 years ago

The problem is in the Rudder technique:

grep "/default/check_rpm_package_installation/packages" logfile
2015-08-19T13:28:24+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:24+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:24+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass 'is_update_action_0.0_update_version_valid.!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:24+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:24+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '(!is_update_action_0|(SuSE.!zypper_version_ok)).!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass 'is_update_action_0.0_update_version_valid.!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '(!is_update_action_0|(SuSE.!zypper_version_ok)).!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass 'is_update_action_0.0_update_version_valid.!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '(!is_update_action_0|(SuSE.!zypper_version_ok)).!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass 'is_update_action_0.0_update_version_valid.!0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Evaluating promise '${rpm_package[${index_rpmpkg}]}'
2015-08-19T13:28:27+0000  verbose: /default/check_rpm_package_installation/packages: Skipping next promise '${rpm_package[${index_rpmpkg}]}', as ifvarclass '0_package_version_defined.!(rpm_package_installation_0_repaired|rpm_package_installation_0_error|rpm_package_installation_0_kept)' is not relevant

The package promise is not evaluated and we still report a success.

      "any" usebundle => rudder_common_report("packageInstallation", "result_success", "${rpm_data[${index_rpmpkg}][3]}", "RHEL/CentOS/SuSE packages", "${rpm_package[${index_rpmpkg}]}", "No action required for RPM package ${rpm_package[${index_rpmpkg}]} with policy: ${rpm_data[${index_rpmpkg}][0]}"),
        ifvarclass => "is_update_action_${index_rpmpkg}.!${index_rpmpkg}_package_version_defined.(rpm_package_installation_updated_available_packages_kept|rpm_package_installation_updated_available_packages_repaired).!${index_rpmpkg}_update_version_valid";

should probably be split and return a result_error if the package does not exist on the system.

#3 Updated by Alexis MOUSSET over 3 years ago

  • Target version set to 2.11.13

The problem seems to exist since the 6.1 version of the technique.

#4 Updated by Jonathan CLARKE almost 3 years ago

  • Related to Bug #3040: Package management for RHEL / CentOS / SuSE / RPM systems : Reporting about installation is wrong when a package is not available or met dependencies problem added

#5 Updated by Jonathan CLARKE almost 3 years ago

Looks very similar to #3040.

#6 Updated by Alexis MOUSSET over 2 years ago

#7 Updated by Benoît PECCATTE over 2 years ago

  • Target version changed from 2.11.13 to 2.11.21

#8 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.21 to 2.11.22

#9 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.22 to 2.11.23

#10 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.23 to 2.11.24

#11 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 2.11.24 to 308

#12 Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 308 to 3.1.14

#13 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.14 to 3.1.15

#14 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.15 to 3.1.16

#15 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.16 to 3.1.17

#16 Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 3.1.17 to 3.1.18

#17 Updated by Vincent MEMBRÉ almost 2 years ago

  • Target version changed from 3.1.18 to 3.1.19

#18 Updated by Jonathan CLARKE over 1 year ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings

#19 Updated by Benoît PECCATTE over 1 year ago

  • Priority set to 30

#20 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.19 to 3.1.20

#21 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.20 to 3.1.21

#22 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.21 to 3.1.22

#23 Updated by Benoît PECCATTE over 1 year ago

  • Priority changed from 30 to 43

#24 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.22 to 3.1.23

#25 Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 3.1.23 to 3.1.24

#26 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.24 to 3.1.25

#27 Updated by Vincent MEMBRÉ about 1 year ago

  • Target version changed from 3.1.25 to 387

#28 Updated by Vincent MEMBRÉ 12 months ago

  • Target version changed from 387 to 4.1.10

#29 Updated by Vincent MEMBRÉ 10 months ago

  • Target version changed from 4.1.10 to 4.1.11

#30 Updated by Vincent MEMBRÉ 8 months ago

  • Target version changed from 4.1.11 to 4.1.12

#31 Updated by Vincent MEMBRÉ 7 months ago

  • Target version changed from 4.1.12 to 4.1.13

#32 Updated by Vincent MEMBRÉ 5 months ago

  • Target version changed from 4.1.13 to 4.1.14

#33 Updated by Benoît PECCATTE 4 months ago

  • Target version changed from 4.1.14 to 4.1.15

#34 Updated by Vincent MEMBRÉ about 2 months ago

  • Target version changed from 4.1.15 to 4.1.16
  • Priority changed from 43 to 44

#35 Updated by Vincent MEMBRÉ about 1 month ago

  • Target version changed from 4.1.16 to 4.1.17

#36 Updated by François ARMAND 29 days ago

  • Status changed from New to Rejected
  • Priority changed from 44 to 0

The correct correction for that ticket is to use the "package" technique. I'm closing it. If you can't use package technique and are impacted by that ticket, please let us know!

Also available in: Atom PDF