Project

General

Profile

Actions

Bug #7248

closed

No user/group creation methods available

Added by Olivier Mauras almost 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
1
Assignee:
-
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

There's a lack of user/group creation - with local creation enforcement and UID/GID support - method in NCF
This is a must need!


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #5758: Add generic method to create user/groupsReleasedJonathan CLARKEActions
Actions #1

Updated by Vincent MEMBRÉ almost 7 years ago

  • Priority changed from 2 to 1
  • Target version set to 0.x

Yeah this clearly miss and we always say 'we need to add them'

I guess there should be several methods :

  • user_add
  • user_delete
  • group_add
  • group_delete

don't know if we need a specific user_modify method or that user_add should be user_management with a 'create if missing' flag.

I also think we should not do like packages and have 'default' values for user_add (default shell, ...) so we don't have to create methods like
user_add_shell, user_add_shell_group user_add_group ... (like we did for packages ...)

Actions #2

Updated by Benoît PECCATTE almost 7 years ago

  • Is duplicate of User story #5758: Add generic method to create user/groups added
Actions #3

Updated by Benoît PECCATTE almost 7 years ago

  • Status changed from New to Rejected

I completely agree with this.
But I'm closing it in favor of the older existing issue: #5758

Actions #4

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #5

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF