Project

General

Profile

Actions

Question #7275

closed

Could not write technique 'create_dir'

Added by Francois BAYART about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
N/A
Category:
Web - Technique editor
Target version:
Regression:

Description

I have an error with ncf editor and I don't know how to fix it or in which direction to check. I have this problem only on my production server and not on test (...) so I would like to find a solution.

When I click on techniques editor and create a simple techniques with 1 method like "create a directory" I get this message :

"An Error occured! Could not write technique 'create_dir' from path /var/rudder/configuration-repository/ncf, cause is: Error while running post-hook command [u'/var/rudder/configuration-repository/ncf/ncf-hooks.d/post.write_technique.rudderify.sh', u'/var/rudder/configuration-repository/ncf', u'create_dir']
Details: INFO: Alternative source path added: /var/rudder/configuration-repository/ncf Error: Unable to create Rudder Technique files related to ncf Technique create_dir ([Errno 13] Permission denied: '/var/rudder/configuration-repository/techniques/ncf_techniques/create_dir/1.0') Traceback (most recent call last): File "/usr/share/ncf/tools/ncf_rudder.py", line 46, in write_one_technique_for_rudder write_technique_for_rudder(destination_path, metadata) File "/usr/share/ncf/tools/ncf_rudder.py", line 120, in write_technique_for_rudder os.makedirs(path) File "/usr/lib/python2.7/os.py", line 157, in makedirs mkdir(name, mode) OSError: [Errno 13] Permission denied: '/var/rudder/configuration-repository/techniques/ncf_techniques/create_dir/1.0'"

I don't know if the problem is new or old, I have discovered this when I was importing a new NCF techniques over API. I have make an error during the import I wrote "techniques" instead of "technique" in JSON header { "path" : "/var/rudder/configuration-repository/ncf",
"*technique*": {

Could be the source of problem ?


Files

2015-10-13_16-03-08.png (222 KB) 2015-10-13_16-03-08.png Francois BAYART, 2015-10-13 16:12
Actions

Also available in: Atom PDF