Project

General

Profile

Actions

Bug #7449

closed

rudder-upgrade recommends to use deprecated rudder-server-root init script

Added by Jonathan CLARKE over 5 years ago. Updated over 5 years ago.

Status:
Released
Priority:
N/A
Category:
System integration
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

If a service check fails in rudder-upgrade, it says something like:

INFO: Checking PostgreSQL service status............ FAILED
PostgreSQL service verification failed after 10 tries.
INFO: Checking LDAP service status... OK

ERROR: The migration has failed in some steps. Check previous error messages.
Please restart the failed service(s), and start the migration script again.
(on a single Rudder server, try service rudder-server-root restart)

However, since #6513, "rudder-server-root" init script has been replaced with "rudder".

Actions #1

Updated by Jonathan CLARKE over 5 years ago

  • Status changed from New to In progress
  • Assignee set to Jonathan CLARKE
Actions #2

Updated by Jonathan CLARKE over 5 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Jonathan CLARKE to Benoît PECCATTE
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/804
Actions #3

Updated by Jonathan CLARKE over 5 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100
Actions #5

Updated by Vincent MEMBRÉ over 5 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 3.1.5 which was released today.

Actions

Also available in: Atom PDF