Project

General

Profile

Actions

Bug #7489

closed

Missing Timezones from clockConfiguration

Added by Janos Mattyasovszky over 5 years ago. Updated about 5 years ago.

Status:
Released
Priority:
N/A
Category:
Techniques
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

There are many-many timezones missing from the Clock config technique.

Please have a look at http://www.unicode.org/cldr/charts/latest/supplemental/zone_tzid.html to get a mapping between linux/windows timezones.

It would be also nice to use an additional input box as "custom" additional to the drop-down menu, so this could be set via Node-Property or generic_variable_definition, as this is a one-technique-per-node setting, so having one rule to rule them all is not applicable, when not all your servers are in one timezone (which is not always the case ;-))

Related to #7488


Subtasks 1 (0 open1 closed)

Bug #7956: Add clockConfiguration version 3.1 to supported technique versionsReleasedBenoît PECCATTE2016-02-22Actions

Related issues

Related to Rudder - Bug #7488: clockConfiguration sets RTC to localtimeRejected2015-11-27Actions
Related to Rudder - Bug #7501: Technique "Clock settings" uses Europe/Paris as China's timezone (technique version 3.0)ReleasedJonathan CLARKEActions
Related to Rudder - Bug #8009: Fix invalid metadata.xml statement in clockSettings 3.1ReleasedJanos Mattyasovszky2016-03-01Actions
Is duplicate of Rudder - User story #7598: Add features to Time settings (RTC to UTC/Localtime; all timezones)DiscussionActions
Actions #1

Updated by Janos Mattyasovszky over 5 years ago

  • Description updated (diff)
Actions #2

Updated by Jonathan CLARKE over 5 years ago

  • Related to Bug #7488: clockConfiguration sets RTC to localtime added
Actions #3

Updated by Jonathan CLARKE over 5 years ago

  • Related to Bug #7501: Technique "Clock settings" uses Europe/Paris as China's timezone (technique version 3.0) added
Actions #4

Updated by Janos Mattyasovszky over 5 years ago

Handled in #7598

Actions #5

Updated by Jonathan CLARKE over 5 years ago

Closing in favour of #7598.

Actions #6

Updated by Jonathan CLARKE over 5 years ago

  • Is duplicate of User story #7598: Add features to Time settings (RTC to UTC/Localtime; all timezones) added
Actions #7

Updated by Jonathan CLARKE over 5 years ago

  • Status changed from New to Rejected
Actions #8

Updated by Janos Mattyasovszky about 5 years ago

  • Status changed from Rejected to New
  • Assignee set to Jonathan CLARKE
  • Target version set to 2.11.19
  • Found in version(s) old 2.11.17 added
  • Found in version(s) old deleted (3.0.9)
Actions #9

Updated by Janos Mattyasovszky about 5 years ago

  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/860

Proposed PR: https://github.com/Normation/rudder-techniques/pull/860

As discussed on IRC: Backport of all TZ's with minimal impact on clockSetting technique version 3, with no change to reporting / input parameters.

Actions #10

Updated by Janos Mattyasovszky about 5 years ago

  • Status changed from New to Pending release
  • % Done changed from 0 to 100
Actions #11

Updated by Nicolas CHARLES about 5 years ago

  • Related to Bug #8009: Fix invalid metadata.xml statement in clockSettings 3.1 added
Actions #12

Updated by Vincent MEMBRÉ about 5 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.11.19, 3.0.14, 3.1.8 and 3.2.1 which were released today.

Actions

Also available in: Atom PDF