Project

General

Profile

Actions

Bug #7522

closed

schedule_simple fails

Added by Jonathan CLARKE almost 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

----------------------------------------------------------------------
./30_generic_methods/schedule_simple.cf
----------------------------------------------------------------------
R: [ERROR] Promise could not be repaired, error encountered: Scheduling test1
R: TEST result ERROR test1: error test1_error false
R: TEST result OK test1
R: [ERROR] Promise could not be repaired, error encountered: Scheduling test2
R: TEST result ERROR test2: error test2_error false
R: TEST result OK test2
R: [ERROR] Promise could not be repaired, error encountered: Scheduling test3
R: TEST result ERROR test3: error test3_error false
R: TEST result OK test3
R: TEST result ERROR test4: current_run 9 != 0
R: TEST result ERROR test4: run ${schedule_generic.run_id} != 1
R: TEST result ERROR test5: current_run 9 != 1
R: TEST result ERROR test6: current_run 349 != 1
R: /usr/rudder-tests/ncf/tests/acceptance/./30_generic_methods/schedule_simple.cf FAIL

Return code is 0.

  ==> FAIL

This is at least related to the use of the date command:

# date --date='01/01/01 00:01' +%s
date: illegal option -- -
Usage: date [-n][-u] [mmddHHMM[[cc]yy]] [+Field Descriptors]
Usage: date [-n][-u] [mmddHHMM[.SS[cc]yy]] [+Field Descriptors]
Usage: date [-a] [[+|-]sss.fff]

Related issues 2 (0 open2 closed)

Related to Rudder - Bug #7521: Tests do not work on AIXReleasedBenoît PECCATTEActions
Related to Rudder - Bug #7500: Errors in inform output about 'assumed integer value' due to time_lib.cfReleasedJonathan CLARKEActions
Actions #1

Updated by Jonathan CLARKE almost 7 years ago

  • Related to Bug #7521: Tests do not work on AIX added
Actions #2

Updated by Jonathan CLARKE almost 7 years ago

  • Subject changed from schedule_simple fails on AIX to schedule_simple fails
Actions #3

Updated by Jonathan CLARKE almost 7 years ago

This also fails on Linux, now:

----------------------------------------------------------------------
./30_generic_methods/schedule_simple.cf
----------------------------------------------------------------------
R: [ERROR] Promise could not be repaired, error encountered: Scheduling test1
R: TEST result ERROR test1: error test1_error false
R: TEST result OK test1
R: [ERROR] Promise could not be repaired, error encountered: Scheduling test2
R: TEST result ERROR test2: error test2_error false
R: TEST result OK test2
R: [ERROR] Promise could not be repaired, error encountered: Scheduling test3
R: TEST result ERROR test3: error test3_error false
R: TEST result OK test3
R: TEST result ERROR test4: current_run 0 != 0
R: TEST result ERROR test4: run ${schedule_generic.run_id} != 1
R: TEST result OK test4
R: TEST result ERROR test5: current_run 1 != 1
R: TEST result OK test5
R: TEST result OK test6
R: /home/jclarke/COMMUNAUTES/ncf/tests/acceptance/./30_generic_methods/schedule_simple.cf FAIL
Actions #4

Updated by Jonathan CLARKE almost 7 years ago

  • Related to Bug #7500: Errors in inform output about 'assumed integer value' due to time_lib.cf added
Actions #5

Updated by Jonathan CLARKE almost 7 years ago

  • Status changed from New to Rejected

This was fixed by #7500

Actions #6

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #7

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF