Project

General

Profile

Actions

Bug #8141

closed

On rules creation, we may get a never stopping spining wheel on rules list

Added by Nicolas CHARLES about 8 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Compliance & node report
Target version:
Severity:
Trivial - no functional impact | cosmetic
UX impact:
User visibility:
Getting started - demo | first install | level 1 Techniques
Effort required:
Priority:
0
Name check:
Fix check:
Regression:

Description

When we create a Rule, promise get generated. While it is not fully generated, info for expected reports are not available, and so we get a spining wheel when showing compliance (for rules and reports)
But, the wheel never stops to spin, unless we reload page after end of generation
It should stop at some point (and even never start when compliance is disabled)


Related issues 3 (0 open3 closed)

Related to Rudder - Bug #7336: Node stuck in "Applying" statusRejectedFrançois ARMANDActions
Related to Rudder - Bug #8030: When a node doesn't have expected reports, we have a spinning wheel in place of complianceRejectedFrançois ARMANDActions
Is duplicate of Rudder - Bug #7281: Compliance keeps on loading while expected reports are not available for a node or a ruleReleasedFrançois ARMANDActions
Actions #1

Updated by Nicolas CHARLES about 8 years ago

if rules isn't applied to nodes, the spinning wheel will never ever end

Actions #2

Updated by Nicolas CHARLES about 8 years ago

  • Translation missing: en.field_tag_list set to sponsored
Actions #3

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 3.0.15 to 3.0.16
Actions #4

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 3.0.16 to 3.0.17
Actions #5

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 3.0.17 to 2.11.23
Actions #6

Updated by Vincent MEMBRÉ about 8 years ago

  • Target version changed from 2.11.23 to 302
Actions #7

Updated by Alexis Mousset about 8 years ago

  • Target version changed from 302 to 3.1.12
Actions #8

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.12 to 3.1.13
Actions #9

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 3.1.13 to 3.1.14
Actions #10

Updated by François ARMAND over 7 years ago

  • Related to Bug #7336: Node stuck in "Applying" status added
Actions #11

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #12

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #13

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #14

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #15

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #16

Updated by Jonathan CLARKE over 7 years ago

  • Severity set to Trivial - no functional impact | cosmetic
  • User visibility set to Getting started - demo | first install | level 1 Techniques
Actions #17

Updated by Jonathan CLARKE over 7 years ago

  • Related to Bug #8030: When a node doesn't have expected reports, we have a spinning wheel in place of compliance added
Actions #18

Updated by Benoît PECCATTE about 7 years ago

  • Priority set to 47
Actions #19

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #20

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #21

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
Actions #22

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 47 to 60
Actions #23

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #24

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #25

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #26

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
  • Priority changed from 60 to 66
Actions #27

Updated by François ARMAND over 6 years ago

  • Related to Bug #7281: Compliance keeps on loading while expected reports are not available for a node or a rule added
Actions #28

Updated by François ARMAND over 6 years ago

  • Related to deleted (Bug #7281: Compliance keeps on loading while expected reports are not available for a node or a rule)
Actions #29

Updated by François ARMAND over 6 years ago

  • Is duplicate of Bug #7281: Compliance keeps on loading while expected reports are not available for a node or a rule added
Actions #30

Updated by François ARMAND over 6 years ago

  • Status changed from New to Rejected

Duplicates #7281

Actions #31

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 3.1.25
Actions #32

Updated by Alexis Mousset about 2 years ago

  • Priority changed from 66 to 0
Actions

Also available in: Atom PDF