Project

General

Profile

Actions

User story #8148

closed

Backport CFEngine patches

Added by Alexis MOUSSET about 5 years ago. Updated almost 5 years ago.

Status:
Released
Priority:
N/A
Category:
Agent
Target version:
Suggestion strength:
User visibility:
Effort required:

Description

All versions: For 2.11 and 3.0 only:

Subtasks 6 (0 open6 closed)

User story #8153: Backport CFEngine patches to 3.1ReleasedJonathan CLARKE2016-05-24Actions
User story #8365: Backport CFEngine patches to 3.2ReleasedJonathan CLARKE2016-05-24Actions
Bug #8366: 8365 broke agent buildRejectedBenoît PECCATTE2016-05-24Actions
Bug #8367: Missing patch in 8153ReleasedBenoît PECCATTE2016-05-24Actions
User story #8324: Backport fix for >1K long classes in the agentReleasedJonathan CLARKE2016-05-18Actions
User story #8375: Backport cf-promises segfault in json read fix for >3.2ReleasedJonathan CLARKE2016-05-25Actions

Related issues

Is duplicate of Rudder - Bug #5712: Defining long classes (about > 2064 char) in CFEngine causes segfaultRejectedAlexis MOUSSET2014-10-22Actions
Actions #1

Updated by Alexis MOUSSET about 5 years ago

  • Is duplicate of Bug #5712: Defining long classes (about > 2064 char) in CFEngine causes segfault added
Actions #2

Updated by Alexis MOUSSET about 5 years ago

  • Status changed from New to Rejected
Actions #3

Updated by Alexis MOUSSET about 5 years ago

  • Status changed from Rejected to New
Actions #4

Updated by Benoît PECCATTE about 5 years ago

  • Target version set to Ideas (not version specific)
Actions #5

Updated by Alexis MOUSSET almost 5 years ago

All versions: For 2.11 and 3.0 only:
Actions #6

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from Ideas (not version specific) to 2.11.21
Actions #7

Updated by Vincent MEMBRÉ almost 5 years ago

  • Status changed from New to Pending technical review
Actions #8

Updated by Vincent MEMBRÉ almost 5 years ago

  • Status changed from Pending technical review to 12
Actions #9

Updated by Vincent MEMBRÉ almost 5 years ago

  • Status changed from 12 to Pending release
Actions #10

Updated by Vincent MEMBRÉ almost 5 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.11.21, 3.0.16, 3.1.10 and 3.2.3 which were released on 2016-06-01, but not announced.

Actions

Also available in: Atom PDF