Project

General

Profile

Actions

Bug #8167

closed

package_install_version_cmp_update should handle all needed package operations

Added by Alexis Mousset over 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

  • Ensure latest version
  • Ensure specific version
  • Ensure installed with no other constraint

It should handle install/updates in a transparent way when needed.

Rudder package techniques should then use the ncf generic method.


Related issues 6 (0 open6 closed)

Related to Rudder - Bug #8150: Update does not work in package_install_version_cmp_updateReleasedNicolas CHARLESActions
Related to Rudder - Bug #8121: Clear package caches when repairing a package repositoryReleasedBenoƮt PECCATTEActions
Related to Rudder - User story #6994: Technique aptPackageInstallation doesn't update packages if no version is definedRejectedActions
Related to Rudder - User story #8230: Package management issues in Rudder/ncfRejectedAlexis MoussetActions
Related to Rudder - Bug #9547: package_install should use another package body when using a specific package versionReleasedNicolas CHARLESActions
Is duplicate of Rudder - User story #8952: Add generic methods using new package promisesReleasedJonathan CLARKEActions
Actions #1

Updated by Alexis Mousset over 6 years ago

  • Related to Bug #8150: Update does not work in package_install_version_cmp_update added
Actions #2

Updated by Alexis Mousset over 6 years ago

  • Related to Bug #8121: Clear package caches when repairing a package repository added
Actions #3

Updated by Alexis Mousset over 6 years ago

  • Related to User story #6994: Technique aptPackageInstallation doesn't update packages if no version is defined added
Actions #4

Updated by Alexis Mousset over 6 years ago

We could create a _package_clear_caches generic method to be called from techniques which need it.

Actions #5

Updated by Alexis Mousset over 6 years ago

Actions #6

Updated by Alexis Mousset about 6 years ago

  • Category set to Generic methods
Actions #7

Updated by Alexis Mousset almost 6 years ago

  • Related to Bug #9547: package_install should use another package body when using a specific package version added
Actions #8

Updated by Alexis Mousset over 5 years ago

  • Status changed from New to Rejected

Done in package_state/present/absent (#8952)

Actions #9

Updated by Alexis Mousset over 5 years ago

  • Is duplicate of User story #8952: Add generic methods using new package promises added
Actions #10

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #11

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF