Project

General

Profile

Bug #8277

Reporting broken on RPM package install technique

Added by Alexis MOUSSET almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
N/A
Category:
Techniques
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

I see regularly, on some machines, these two message fro the same component:

  • No action required for ...
  • RPM package ... was correct

It breaks reporting, and seems to happen when caches are refreshed.


Related issues

Is duplicate of Rudder - Bug #8421: Invalidation of previous package state and of package status cache does not work on rpmPackageInstallation 5.0 5.1 6.0 6.1 7.0ReleasedNicolas CHARLES2016-05-30Actions
#1

Updated by Benoît PECCATTE almost 5 years ago

  • Subject changed from Reporting broen on RPM package install technique to Reporting broken on RPM package install technique
#2

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.11.21 to 2.11.22
#3

Updated by Jonathan CLARKE almost 5 years ago

  • Status changed from New to In progress
  • Assignee set to Jonathan CLARKE

Alexis MOUSSET wrote:

I see regularly, on some machines, these two message fro the same component:

  • No action required for ...
  • RPM package ... was correct

The first report comes from a hardcoded success report in the technique:

      "any" usebundle => rudder_common_report_index("packageInstallation", "result_success", "${rpm_data[${index_rpmpkg}][3]}", "RHEL/CentOS/SuSE packages", "${rpm_package[${index_rpmpkg}]}", "No action required for RPM package ${rpm_package[${index_rpmpkg}]} with policy: ${rpm_data[${index_rpmpkg}][0]}", "${index_rpmpkg}"),
        ifvarclass => "is_update_action_${index_rpmpkg}.!${index_rpmpkg}_package_version_defined.(rpm_package_installation_updated_available_packages_kept|rpm_package_installation_updated_available_packages_repaired).!${index_rpmpkg}_update_version_valid";

This second report comes from a call to:

rudder_common_reports_generic_index(..., "rpm_package_installation_${index_rpmpkg}", ..., "RPM package ${rpm_package[${index_rpmpkg}]} with policy: ${rpm_data[${index_rpmpkg}][0]}")
#4

Updated by Jonathan CLARKE almost 5 years ago

  • Related to Bug #8421: Invalidation of previous package state and of package status cache does not work on rpmPackageInstallation 5.0 5.1 6.0 6.1 7.0 added
#5

Updated by Jonathan CLARKE almost 5 years ago

  • Status changed from In progress to Discussion
  • Assignee changed from Jonathan CLARKE to Alexis MOUSSET

There is a high chance this bug was caused by #8421. That would be the case if you only saw this double reporting just after a policy update on the node, which may or may not coincide (but probably does) with a change in the directive's settings.

Could you check to see if you still get this with the fix for #8421 please Alexis?

#6

Updated by Jonathan CLARKE almost 5 years ago

  • Status changed from Discussion to Rejected

Jonathan CLARKE wrote:

There is a high chance this bug was caused by #8421. That would be the case if you only saw this double reporting just after a policy update on the node, which may or may not coincide (but probably does) with a change in the directive's settings.

Could you check to see if you still get this with the fix for #8421 please Alexis?

Tests seem to have confirmed this was fixed by #8421. Closing as a duplicate.

#7

Updated by Jonathan CLARKE almost 5 years ago

  • Related to deleted (Bug #8421: Invalidation of previous package state and of package status cache does not work on rpmPackageInstallation 5.0 5.1 6.0 6.1 7.0)
#8

Updated by Jonathan CLARKE almost 5 years ago

  • Is duplicate of Bug #8421: Invalidation of previous package state and of package status cache does not work on rpmPackageInstallation 5.0 5.1 6.0 6.1 7.0 added
#9

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 2.11.22 to 2.11.23

Also available in: Atom PDF