Project

General

Profile

Actions

Bug #8573

closed

Smelly code in logger_rudder

Added by Benoît PECCATTE over 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

In logger_rudder.cf, we have the following code twice

(logger_rudder_final_resfile_repaired|logger_rudder_temp_resfile_kept.!logger_rudder_temp_resfile_repaired.final_resfile_exists)::

The parens are either unneeded or at the wrong place.
Either way, there should be parens somewhere since we mix AND and OR.

Actions #1

Updated by Alexis Mousset about 6 years ago

  • Category set to Generic methods
Actions #2

Updated by Alexis Mousset almost 6 years ago

  • Status changed from New to Rejected

This has been removed since the refactoring in #9203.

Actions #3

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #4

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF