Project

General

Profile

Actions

Bug #8623

closed

Method "File ensure block in section" of Technique Editor cuts the block to 2047 bytes

Added by Dmitry Svyatogorov over 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Web - Technique editor
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Rudder v.3.2.4 - © Normation (prepackaged from http://www.rudder-project.org/apt-3.2/) @ Ubuntu 14.04.3 LTS

  1. Save the large block (the multipath aliases of /etc/multipath.conf in my case) in Technique Editor. /Save ok. Apply ok./
  2. Reopen technique, make sure "block:" is now containing the first 2047 bytes. (Improper read buffer?)

Note, the actual variable maximum size in cfengine is 16k (grooved from previous 4k), the buffer must be at least 16k in case of static size.

Although, (at least) the leading spaces are cutten at save time for no reason. I consider file content must be stored "as is". /I'll post later the buggy variable screening in file content techniques, if one was not already posted./

Actions #1

Updated by Alexis Mousset over 6 years ago

The editor issue was fixed since last release (see #8544), and will be fixed in the next minor release. The editor now outputs a warn message and does not let a user expand a field over 2k. The limit should be 16k indeed, and we have opened an issue on CFEngine bucktracker, and we we will probably try to fix it.

About the leading spaces, we also fixed this since last release (see #8228). There will be different constraints for the fields, allowing spaces when needed (file content, etc.)

Actions #2

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 3.2.5 to 3.2.6
Actions #3

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 3.2.6 to 3.2.7
Actions #4

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 3.2.7 to 3.2.8
Actions #5

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 3.2.8 to 3.2.9
Actions #6

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 3.2.9 to 3.2.10
Actions #7

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 3.2.10 to 3.2.11
Actions #8

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 3.2.11 to 339
Actions #9

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 339 to 4.0.4
Actions #10

Updated by Alexis Mousset over 5 years ago

  • Project changed from Rudder to 41
  • Category changed from Web - Technique editor to Technique editor - UI/UX
  • Status changed from New to Rejected
  • Target version changed from 4.0.4 to 0.x

We now warn the user (#8544), closing.

Actions #11

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #12

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Technique editor - UI/UX to Web - Technique editor
Actions

Also available in: Atom PDF