Project

General

Profile

Actions

User story #9024

closed

Add conditions on rudder_version in ncf code loading

Added by Alexis Mousset about 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Regression:

Description

It is needed to handle incompatibilities between versions, and because we backport some new functions and need to make the difference between a vanilla CFEngine and a Rudder CFEngine.

Actions #1

Updated by François ARMAND about 6 years ago

  • Related to User story #9039: Add a static rudder version in rudder agent version added
Actions #2

Updated by Benoît PECCATTE about 6 years ago

  • Status changed from New to In progress
  • Assignee set to Benoît PECCATTE
Actions #3

Updated by Benoît PECCATTE about 6 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Benoît PECCATTE to Alexis Mousset
  • Pull Request set to https://github.com/Normation/ncf/pull/443
Actions #4

Updated by Benoît PECCATTE about 6 years ago

  • Status changed from Pending technical review to Rejected

Replaced by #9105

We won't do this feature because it is not needed and relying on it may be a source of future difficulties.
We prefer to add a more fine grained loading using features.

Actions #5

Updated by Benoît PECCATTE about 6 years ago

  • Related to deleted (User story #9039: Add a static rudder version in rudder agent version)
Actions #6

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
Actions #7

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF