Project

General

Profile

Actions

Architecture #9207

closed

Transient policy error after upgrade, need to improve handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques)

Added by Alexis Mousset over 7 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Packaging
Effort required:
Name check:
Fix check:
Regression:

Description

On the server, we upgrade different packages when updating Rudder, particularly the system techniques in Rudder techniques, the ncf sources in the ncf package, and rudder-webapp which start the rudder-upgrade script which updates the policy

We need a way to avoid transient errors like #8792 or #9171 and to avoid doing the update in a random order, with a transient broken state.


Related issues 8 (0 open8 closed)

Related to Rudder - Bug #8792: Transient ncf error when updating from 3.1.10 to 3.1.12Rejected2016-07-29Actions
Related to Rudder - Bug #9171: Broken run on 3.2 after 3.1 upgradeRejected2016-09-28Actions
Related to Rudder - Bug #8710: Cannot read ncf inputs due to duplicated pathRejectedNicolas CHARLES2016-07-19Actions
Related to Rudder - Bug #9416: Transient error during upgrade from 3.1 to 4.0RejectedActions
Related to Rudder - Bug #10028: Transient update error on ncf/localReleasedAlexis MoussetActions
Related to Rudder - Bug #11128: error: Fatal CFEngine error: Augment scope, formal and actual parameter mismatch is fatalRejectedActions
Related to Rudder - Bug #12223: Transient policy generation error at upgrade from 4.2 to 4.3RejectedAlexis MoussetActions
Has duplicate Rudder - Bug #9179: Error when restarting rudder-agent during upgradeRejectedActions
Actions #1

Updated by Alexis Mousset over 7 years ago

  • Related to Bug #8792: Transient ncf error when updating from 3.1.10 to 3.1.12 added
Actions #2

Updated by Alexis Mousset over 7 years ago

  • Related to Bug #9171: Broken run on 3.2 after 3.1 upgrade added
Actions #3

Updated by Alexis Mousset over 7 years ago

  • Tracker changed from User story to Bug
  • Subject changed from Improve handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques) to Policy loading error after upgrade, need to mprove handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques)
  • Reproduced set to No
Actions #4

Updated by Alexis Mousset over 7 years ago

  • Related to Bug #8710: Cannot read ncf inputs due to duplicated path added
Actions #5

Updated by Alexis Mousset over 7 years ago

  • Related to Bug #9416: Transient error during upgrade from 3.1 to 4.0 added
Actions #6

Updated by Alexis Mousset over 7 years ago

  • Subject changed from Policy loading error after upgrade, need to mprove handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques) to Transient policy error after upgrade, need to improve handling of policies update during server upgrade (rudder-upgrade vs. ncf vs. rudder-techniques)
Actions #7

Updated by Nicolas CHARLES over 7 years ago

  • Related to Bug #10028: Transient update error on ncf/local added
Actions #8

Updated by Benoît PECCATTE about 7 years ago

  • Priority set to 0

Alexis, can you elaborate on what the bug is and what the consequences are ?

Actions #9

Updated by Alexis Mousset about 7 years ago

The consequences are transient broken policies on the server, possibly distributed to nodes.

Actions #10

Updated by Benoît PECCATTE about 7 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
Actions #11

Updated by François ARMAND about 7 years ago

  • Tracker changed from Bug to Architecture
Actions #12

Updated by Nicolas CHARLES almost 7 years ago

  • Related to Bug #11128: error: Fatal CFEngine error: Augment scope, formal and actual parameter mismatch is fatal added
Actions #13

Updated by Alexis Mousset over 6 years ago

  • Has duplicate Bug #9179: Error when restarting rudder-agent during upgrade added
Actions #14

Updated by Alexis Mousset about 6 years ago

  • Related to Bug #12223: Transient policy generation error at upgrade from 4.2 to 4.3 added
Actions #15

Updated by Alexis Mousset almost 5 years ago

This should be fixed in 5.1 by the package merge that will allow (more) atomic upgrades.

Actions #16

Updated by Alexis Mousset about 3 years ago

  • Status changed from New to Resolved

Fixed by package merge.

Actions

Also available in: Atom PDF