Project

General

Profile

Actions

Bug #9322

closed

Some runs have no report on ncf if after upgrading from 3.1.13

Added by Nicolas CHARLES almost 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

In Rudder 3.1.13, reports files were not correctly purged, so there are potentially a lot of reports files with different PID
When upgrading to latest version, the files are correctly purged after each run, and the dandling files after x days

It is possible, if reports files did not change, that there is a collision during the x days interval, and tmp and res files are not updated (because they are already correct)
Since reporting depend on the _repaired class, and the result is _kept, no report is made

Note: this is super random, and highly confusing


Related issues 1 (0 open1 closed)

Related to Rudder - Bug #8947: missing rudder_expected_reports.csv.res when starting the agent for the first time after an update - master branchReleasedJonathan CLARKEActions
Actions #1

Updated by Nicolas CHARLES over 5 years ago

  • Related to Bug #8947: missing rudder_expected_reports.csv.res when starting the agent for the first time after an update - master branch added
Actions #2

Updated by Nicolas CHARLES over 5 years ago

  • Status changed from New to Rejected

Rejecting as dupliace of 8947

Actions #3

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #4

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF