Project

General

Profile

Actions

Bug #9632

closed

Rudder agent run fails with Bundle 'ose' not found (update: because --verbose is interpreted -v -e -r -b ose)

Added by Marc Weistroff over 7 years ago. Updated 12 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Agent
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
Fix check:
Regression:
No

Description

I installed Rudder agent 4.0.0~rc5-xenial0 (CFEngine Core 3.7.4). Node cannot be updated.

When I run rudder agen update --verbose, the logs show this error:

rudder     info: Using command line specified bundlesequence
rudder     info: Using command line specified bundlesequence
   error: Bundle 'ose' listed in the bundlesequence was not found
   error: Bundle 'ose' listed in the bundlesequence was not found
   error: Fatal CFEngine error: Errors in agent bundles
   error: Fatal CFEngine error: Errors in agent bundles
rudder  verbose: Outcome of version '(not specified)', no checks were scheduled
rudder  verbose: Outcome of version '(not specified)', no checks were scheduled

Related issues 1 (0 open1 closed)

Related to Rudder - User story #9658: Warn the user when he tries to use long arguments with rudder agentReleasedAlexis Mousset2016-11-10Actions
Actions #1

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 4.0.0 to 4.0.1
Actions #2

Updated by Benoît PECCATTE over 7 years ago

  • Status changed from New to Rejected

Long arguments are not supported, use -v instead of --verbose.

This is interpreted as -v -e -r -b ose the agent then tries to run the ose bundle.

Actions #3

Updated by Benoît PECCATTE over 7 years ago

  • Related to User story #9658: Warn the user when he tries to use long arguments with rudder agent added
Actions #4

Updated by François ARMAND over 7 years ago

@Marc: if you still have an issue about node update unrelated to the particular problem described here, please open an other issue (because I'm thinking that you weren't trying to use "--verbose" for the pleasure of looking at logs).

Thanks!

Actions #5

Updated by Marc Weistroff over 7 years ago

Thanks Benoit and Francois.

It took quite a long time for my node to be updated, but in the end, everything was ok :)

François ARMAND wrote:

@Marc: if you still have an issue about node update unrelated to the particular problem described here, please open an other issue (because I'm thinking that you weren't trying to use "--verbose" for the pleasure of looking at logs).

Thanks!

Actions #6

Updated by François ARMAND 12 months ago

  • Subject changed from Rudder agent run fails to Rudder agent run fails with Bundle 'ose' not found (update: because --verbose is interpreted -v -e -r -b ose)
  • Priority set to 0
  • Regression set to No
Actions

Also available in: Atom PDF