Project

General

Profile

Actions

Bug #9673

closed

"rudder agent update" always ays "ok" even when it could not update the promises

Added by Alexis Mousset over 7 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Agent
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Small
Priority:
30
Name check:
Fix check:
Regression:

Description

We check the reutrn code of cf-agent, but it is 0 even when update fails, we need something better.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #11048: Rudder agent update returns 0 even if update failsReleasedAlexis MoussetActions
Actions #1

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 4.0.1 to 4.0.2
Actions #2

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 4.0.2 to 4.0.3
Actions #3

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 4.0.3 to 4.0.4
Actions #4

Updated by Benoît PECCATTE about 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority set to 16
Actions #5

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.0.4 to 4.0.5
Actions #6

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.0.5 to 4.0.6
  • Priority changed from 16 to 15
Actions #7

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.0.6 to 4.0.7
Actions #8

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 4.0.7 to 357
Actions #9

Updated by Benoît PECCATTE almost 7 years ago

  • Priority changed from 15 to 29
Actions #10

Updated by Benoît PECCATTE almost 7 years ago

  • Effort required set to Small
  • Priority changed from 29 to 32
Actions #11

Updated by Alexis Mousset almost 7 years ago

  • Target version changed from 357 to 4.1.6
Actions #12

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.6 to 4.1.7
Actions #13

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.7 to 4.1.8
  • Priority changed from 32 to 31
Actions #14

Updated by Alexis Mousset over 6 years ago

  • Is duplicate of Bug #11048: Rudder agent update returns 0 even if update fails added
Actions #15

Updated by Alexis Mousset over 6 years ago

  • Status changed from New to Rejected
  • Priority changed from 31 to 30
Actions

Also available in: Atom PDF