Project

General

Profile

Bug #9683

Missing dependency on rsyslog-module-pgsql in rudder-reports

Added by Alexander Brunhirl over 3 years ago. Updated almost 3 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Pull Request:
Severity:
Major - prevents use of part of Rudder | no simple workaround
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Small
Priority:
48

Description

Hi,

in the "rudder-reports" is a missing dependence for "rsyslog-module-pgsql". If this is not installed you didn't get your logs into the database. Whereas "rsyslog" and "postgresql-server" are dependencies it would make sense to add "rsyslog-module-pgsql" as well.

Best regards,
Alex

System: openSuSE Leap 42.1 (same as SLES12 SP1)

# zypper info --requires rudder-reports
Loading repository data...
Reading installed packages...

Information for package rudder-reports:
---------------------------------------
Repository: Rudder Project SLES12 nightly repository
Name: rudder-reports
Version: 1398866025:4.0.1.rc1.git201611170245-1.SLES.12
Arch: noarch
Vendor: Normation
Installed: Yes
Status: out-of-date (version 1398866025:4.0.0.rc6.git201611090222-1.SLES.12 installed)
Installed Size: 10.3 KiB
Summary: Configuration management and audit tool - reports database
Description: 
  Rudder is an open source configuration management and audit solution.

  This packages creates and initializes a PostgreSQL database to receive reports
  sent from nodes managed with Rudder. These reports are used by rudder-webapp to
  calculate compliance to given configuration rules.
Requires:
  /bin/sh
  rsyslog >= 4
  postgresql-server >= 8.4
#

Related issues

Is duplicate of Rudder - Bug #10497: On SLES12, missing package rsyslog-module-pgsqlReleasedNicolas CHARLESActions
#1

Updated by Alexander Brunhirl over 3 years ago

  • Subject changed from Missing dependencie in rudder-reports to Missing dependence in rudder-reports
#2

Updated by Alexander Brunhirl over 3 years ago

  • Description updated (diff)
#3

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 4.0.1 to 4.0.2
#4

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 4.0.2 to 4.0.3
#5

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 4.0.3 to 4.0.4
#6

Updated by Benoît PECCATTE over 3 years ago

  • Found in version (s) 4.0.0 added
#7

Updated by Benoît PECCATTE over 3 years ago

  • Found in version(s) old deleted (4.0.0)
#8

Updated by Benoît PECCATTE over 3 years ago

  • Subject changed from Missing dependence in rudder-reports to Missing dependency in rudder-reports
#9

Updated by Benoît PECCATTE over 3 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority set to 34
#10

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 4.0.4 to 4.0.5
#11

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 4.0.5 to 4.0.6
  • Priority changed from 34 to 33
#12

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 4.0.6 to 4.0.7
#13

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 4.0.7 to 357
#14

Updated by Benoît PECCATTE about 3 years ago

  • Priority changed from 33 to 47
#15

Updated by Benoît PECCATTE about 3 years ago

  • Effort required set to Very Small
  • Priority changed from 47 to 62
#16

Updated by Alexis MOUSSET about 3 years ago

  • Target version changed from 357 to 4.1.6
#17

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 4.1.6 to 4.1.7
  • Priority changed from 62 to 60
#18

Updated by Alexis MOUSSET almost 3 years ago

  • Subject changed from Missing dependency in rudder-reports to Missing dependency on rsyslog-module-pgsql in rudder-reports
  • Effort required changed from Very Small to Small
  • Priority changed from 60 to 48

This dependency should already be included:

%if 0%{?suse_version}
Requires: %{suse_rsyslog_pgsql} >= 4
%endif

Something is probably not working as expected here, setting effort to small.

#19

Updated by Alexis MOUSSET almost 3 years ago

  • Status changed from New to Rejected

In 4.0.1 we had:

%if 0%{?sles_version} && 0%{?sles_version} == 10
Requires: %{suse_rsyslog_pgsql} >= 4
%endif

%if 0%{?sles_version} && 0%{?sles_version} == 11
Requires: %{suse_rsyslog_pgsql} >= 4
%endif

Which is indeed broken on Leap 42. This was fixed in 4.1 by #10497. I'm closing this bug, feel free to reopen if it does not work as expected.

#20

Updated by Alexis MOUSSET almost 3 years ago

  • Is duplicate of Bug #10497: On SLES12, missing package rsyslog-module-pgsql added

Also available in: Atom PDF