Project

General

Profile

Actions

Question #9719

closed

Node deletes are not properly cleaned up

Added by Janos Mattyasovszky over 7 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Performance and scalability
Regression:
No

Description

I just wanted to create a tracking issue for all kind of "node's <xxx> does not get deleted".


Related issues 7 (2 open5 closed)

Related to Rudder - Bug #9609: Deleted node should be periodically fully erased in LDAP (after some ttl)ReleasedNicolas CHARLESActions
Related to Rudder - Bug #9149: Inventory keeps its key certified when node is deletedReleasedFrançois ARMANDActions
Related to Scale-out relay - Bug #7751: When we delete a relay, all system groups and directive related to this relay are not deletedNewElaad FURREEDANActions
Related to Rudder - Bug #7288: Policy does not get deleted when changing relaysNewFrançois ARMANDActions
Related to Rudder - Enhancement #7526: Housekeeping of /var/rudder/inventories/received|failed|etcReleasedVincent MEMBRÉActions
Related to Rudder - Bug #5154: Node key not deleted after deleting a node in the web uiReleasedFrançois ARMANDActions
Has duplicate Rudder - Bug #4709: When a node is deleted, its generated promises are not removedReleasedBenoît PECCATTEActions
Actions #1

Updated by Janos Mattyasovszky over 7 years ago

  • Related to Bug #9609: Deleted node should be periodically fully erased in LDAP (after some ttl) added
Actions #2

Updated by Janos Mattyasovszky over 7 years ago

  • Related to Bug #9149: Inventory keeps its key certified when node is deleted added
Actions #3

Updated by Janos Mattyasovszky over 7 years ago

  • Related to Bug #7751: When we delete a relay, all system groups and directive related to this relay are not deleted added
Actions #4

Updated by Janos Mattyasovszky over 7 years ago

  • Related to Bug #7288: Policy does not get deleted when changing relays added
Actions #5

Updated by Janos Mattyasovszky over 7 years ago

  • Related to Bug #4709: When a node is deleted, its generated promises are not removed added
Actions #6

Updated by François ARMAND over 7 years ago

Thanks for the summary, very much appreciated!

Actions #7

Updated by Janos Mattyasovszky over 7 years ago

  • Related to Enhancement #7526: Housekeeping of /var/rudder/inventories/received|failed|etc added
Actions #8

Updated by Benoît PECCATTE over 7 years ago

  • Category set to Performance and scalability
  • Target version set to 3.1.19
Actions #9

Updated by François ARMAND over 7 years ago

  • Related to Bug #5154: Node key not deleted after deleting a node in the web ui added
Actions #10

Updated by François ARMAND over 7 years ago

  • Related to deleted (Bug #4709: When a node is deleted, its generated promises are not removed)
Actions #11

Updated by François ARMAND over 7 years ago

  • Has duplicate Bug #4709: When a node is deleted, its generated promises are not removed added
Actions #12

Updated by François ARMAND over 7 years ago

  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority set to 16
Actions #13

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 3.1.19 to 3.1.20
Actions #14

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.20 to 3.1.21
Actions #15

Updated by Vincent MEMBRÉ about 7 years ago

  • Target version changed from 3.1.21 to 3.1.22
  • Priority changed from 16 to 15
Actions #16

Updated by Benoît PECCATTE about 7 years ago

  • Priority changed from 15 to 29
Actions #17

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.22 to 3.1.23
Actions #18

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
  • Priority changed from 29 to 28
Actions #19

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
  • Priority changed from 28 to 27
Actions #20

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
Actions #21

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
Actions #22

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
Actions #23

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
Actions #24

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
Actions #25

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #26

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
Actions #27

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #28

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #29

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 27 to 0
Actions #30

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #31

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #32

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #33

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #34

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #35

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #36

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #37

Updated by François ARMAND about 5 years ago

  • Target version changed from 588 to 5.0.13
Actions #38

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #39

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #40

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #41

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #42

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #43

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #44

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #45

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #46

Updated by Benoît PECCATTE about 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #47

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #48

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #49

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #50

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #51

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #52

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #53

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #54

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #55

Updated by Vincent MEMBRÉ over 1 year ago

  • Tracker changed from Bug to Question
  • Status changed from New to Resolved
  • Severity deleted (Minor - inconvenience | misleading | easy workaround)
  • User visibility deleted (Operational - other Techniques | Technique editor | Rudder settings)
  • Priority deleted (0)
  • Regression set to No

I setting this issue as resolved since it is used to track changes on other topics

Actions

Also available in: Atom PDF