Project

General

Profile

Bug #9793

Cannot parse inventory with process using 2GB+ memory

Added by Janos Mattyasovszky over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
-
Target version:
-
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

Received this from our 2TB-RAM Systems:

(NB: You have a formatting error on 2016-12-08 08:46:14.223:WARN:oejs.ServletHandler)

[2016-12-08 08:46:13] INFO  com.normation.inventory.provisioning.endpoint.FusionReportEndpoint - New input inventory: 'verybigsystem-110fcbde-a36e-xxxxxxx.ocs'
[2016-12-08 08:46:14] WARN  com.normation.inventory.provisioning.fusion.PostUnmarshallCheckConsistency - Missing MACHINEID tag, adding an empty one for consistency
2016-12-08 08:46:14.223:WARN:oejs.ServletHandler:
org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NumberFormatExce
ption: For input string: "2660691572" 
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:965)
        at org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:855)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
        at org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:829)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
        at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:652)
        at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:445)
        at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
        at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:556)
        at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:227)
        at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1044)
        at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:372)
        at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:189)
        at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:978)
        at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
        at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
        at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:154)
        at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
        at org.eclipse.jetty.server.Server.handle(Server.java:369)
        at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:486)
        at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:933)
        at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:995)
        at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:651)
        at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
        at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
        at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:667)
        at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)
        at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
        at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
        at java.lang.Thread.run(Thread.java:798)
Caused by:
java.lang.NumberFormatException: For input string: "2660691572" 
        at java.lang.NumberFormatException.forInputString(NumberFormatException.java:77)
        at java.lang.Integer.parseInt(Integer.java:507)
        at java.lang.Integer.parseInt(Integer.java:539)

Found this in the inventory as:

ruddersrv:/var/rudder/inventories # grep -r "2660691572" .
./accepted-nodes-updates/verybigsystem-110fcbde-a36e-xxxxxxx.ocs:      <VIRTUALMEMORY>2660691572</VIRTUALMEMORY>

Apparently this is caused by a DB process consuming that much memory:

    <PROCESSES>
      <CMD>verybigprocess</CMD>
      <CPUUSAGE>180</CPUUSAGE>
      <MEM>83.2</MEM>
      <PID>243438</PID>
      <STARTED>2016-10-30 02:16</STARTED>
      <TTY>?</TTY>
      <USER>username</USER>
      <VIRTUALMEMORY>2660691572</VIRTUALMEMORY>
    </PROCESSES>

Related issues

Has duplicate Rudder - Bug #9077: Inventory "toInt" error when parsing report with VIRTUALMEMORY = 2297795780ReleasedVincent MEMBRÉ2016-09-16Actions
#1

Updated by Janos Mattyasovszky over 4 years ago

  • Subject changed from Cannot parse 2TB Memory from inventory to Cannot parse from inventory with process using 2GB+ memory
#2

Updated by Janos Mattyasovszky over 4 years ago

  • Subject changed from Cannot parse from inventory with process using 2GB+ memory to Cannot parse inventory with process using 2GB+ memory
#3

Updated by Janos Mattyasovszky over 4 years ago

  • Has duplicate Bug #9077: Inventory "toInt" error when parsing report with VIRTUALMEMORY = 2297795780 added
#4

Updated by François ARMAND over 4 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF