Project

General

Profile

Actions

Bug #6696

closed

aptitude hangs on unsigned packages

Added by Alexis Mousset over 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
Matthieu CERDA
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

In 20_cfe_basics/cfengine/packages.cf :

have_aptitude::
   package_add_command => "$(debian_knowledge.call_aptitude) $(debian_knowledge.dpkg_options) --assume-yes install";
   package_list_update_command => "/usr/bin/aptitude update";
   package_delete_command => "$(debian_knowledge.call_aptitude) $(debian_knowledge.dpkg_options) --assume-yes -q remove";
   package_update_command =>  "$(debian_knowledge.call_aptitude) $(debian_knowledge.dpkg_options) --assume-yes install";
   package_patch_command =>  "$(debian_knowledge.call_aptitude) $(debian_knowledge.dpkg_options) --assume-yes install";
   package_verify_command =>  "/usr/bin/aptitude show";
   package_noverify_regex => "(State: not installed|E: Unable to locate package .*)";

   package_patch_list_command => "/usr/bin/aptitude --assume-yes --simulate --verbose full-upgrade";
   package_patch_name_regex => "^Inst\s+(\S+)\s+.*";
   package_patch_version_regex => "^Inst\s+\S+\s+\[?\(?([^\],\s]+).*";

package_patch_list_command uses directly /usr/bin/aptitude instead of $(debian_knowledge.call_aptitude) (which adds the DEBIAN_FRONTEND=noninteractive env var).

This has been fixed in cfengine (3.5 and 3.6), we could update the ncf stdlib.


Related issues 3 (0 open3 closed)

Related to Rudder - Bug #8621: Agent uses malfunctioning "aptitude" for updates checking in debian|ununtuRejectedActions
Related to Rudder - Bug #13305: old packages generic methods are failing on old debianReleasedAlexis MoussetActions
Is duplicate of Rudder - Bug #6425: Generic method for installing package freeze on debian with untrusted sourcesRejectedActions
Actions #1

Updated by Alexis Mousset over 7 years ago

  • Is duplicate of Bug #6425: Generic method for installing package freeze on debian with untrusted sources added
Actions #2

Updated by Matthieu CERDA over 7 years ago

  • Status changed from New to In progress
  • Assignee set to Matthieu CERDA
Actions #3

Updated by Alexis Mousset over 7 years ago

  • Subject changed from aptitude called without DEBIAN_FRONTEND=noninteractive to aptitude hangs on unsigned packages

Sadly this is not enough for unsigned packages: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773715.

It seems there is no fix available for this issue.

Actions #4

Updated by Matthieu CERDA over 7 years ago

We should at least resync ncf's stdlib with CFEngine's one, there are missing elements here.

Actions #5

Updated by Alexis Mousset about 7 years ago

  • Status changed from In progress to Rejected
Actions #6

Updated by Alexis Mousset about 7 years ago

The cfengine stdlib has been resynchronised in #6415.

A workaround for the aptitude issue is to use the -o Aptitude::Cmdline::ignore-trust-violations=true option.

Actions #7

Updated by Alexis Mousset about 6 years ago

  • Related to Bug #8621: Agent uses malfunctioning "aptitude" for updates checking in debian|ununtu added
Actions #8

Updated by Alexis Mousset about 4 years ago

  • Related to Bug #13305: old packages generic methods are failing on old debian added
Actions #9

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #10

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF