Project

General

Profile

User story #10218

Hide unused techniques for which all versions are deprecated

Added by François ARMAND over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
2
Assignee:
-
Category:
Web - Config management
Target version:
Pull Request:
Suggestion strength:
User visibility:
Effort required:

Description

By default, we don't want to show unused techniques for which all technique version are deprecated. We only want to show them if the user has directives based on these technique, but not spoil new user with stuff that will removed soon (and was deprecated for good reason, generaly because a much better alternative is available).

Context: in 4.0, we deprecated old rpm&deb package management technique and we introduced a new, working, unified package management technique. That technique is better than the old specialised alternative for debian/rpm, and should always be used to manage package in place of them. But we can't remove these technique as proposed in #9813 in 4.1, because people stepping from Rudder LTS version to nex LTS would have 0 way to know that the package techniques they used to use was deprecated, and they couldn't have migrated to the new one. On the other hand, we certainly don't want new user to even look at the old package management technique and get confused about which one they should use. So we come to that solution which allows to:

- still display technique with directive - existing set-up are working as always,
- do not show deprecated stuff to new user on new installation - the evolution of the technique library is clearer,
- automatically hide a technique when all version are deprecated, without more maintenance

It could be interesting to bring that behavior to 3.1, but it's hard to call it a bug correction. And it really become important in 4.1, which is the next LTS and we really want new user of that version to use the new package technique.


Related issues

Related to Rudder - User story #9813: Remove old deprecated package techniquesRejectedActions
Is duplicate of Rudder - User story #10228: Reorder and hide deprecated Techniques in Directive tree ReleasedFrançois ARMANDActions
#1

Updated by François ARMAND over 3 years ago

  • Subject changed from Hide unused techniques for which all version are deprecated to Hide unused techniques for which all versions are deprecated
#2

Updated by François ARMAND over 3 years ago

#3

Updated by François ARMAND over 3 years ago

  • Status changed from New to Rejected

It was done along with #10228

#4

Updated by François ARMAND over 3 years ago

  • Is duplicate of User story #10228: Reorder and hide deprecated Techniques in Directive tree added

Also available in: Atom PDF