Project

General

Profile

Bug #12696

Jetty refuse to start "WARN:oejs.SetUID:main: Error: libsetuid.so could not be found" with oracle JDK on SLES11

Added by François ARMAND about 2 years ago. Updated about 2 years ago.

Status:
Rejected
Priority:
N/A
Category:
Packaging
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

When trying to start rudder-jetty with an oracle JDK jdk1.8.0_171-i586, I get in log file `/var/log/rudder/webapp/yyyy_MM_dd.jetty.log`

2018-05-24 17:36:30.640:WARN:oejs.SetUID:main: Error: libsetuid.so could not be found
2018-05-24 17:36:30.640:WARN:oejx.XmlConfiguration:main: Config error at <Set name="username"><Property name="jetty.setuid.userName" deprecated="jetty.username" default="jetty"/></Set> java.lang.reflect.InvocationTargetException in file:/opt/rudder/jetty/etc/jetty-setuid.xml
2018-05-24 17:36:30.641:WARN:oejx.XmlConfiguration:main: Config error at <Call name="addLifeCycleListener"><Arg>|      <New class="org.eclipse.jetty.setuid.SetUIDListener"><Set name="startServerAsPrivileged"><Property name="jetty.setuid.startServerAsPrivileged" deprecated="jetty.startServerAsPrivileged" default="false"/></Set><Set name="umaskOctal"><Property name="jetty.setuid.umask" deprecated="jetty.umask" default="002"/></Set><Set name="username"><Property name="jetty.setuid.userName" deprecated="jetty.username" default="jetty"/></Set><Set name="groupname"><Property name="jetty.setuid.groupName" deprecated="jetty.groupname" default="jetty"/></Set></New>|    </Arg></Call> java.lang.reflect.InvocationTargetException in file:/opt/rudder/jetty/etc/jetty-setuid.xml
2018-05-24 17:36:30.641:WARN:oejx.XmlConfiguration:main:
java.security.PrivilegedActionException: java.lang.reflect.InvocationTargetException
        at java.security.AccessController.doPrivileged(Native Method)
        at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1507)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
....
more more more
....
        at org.eclipse.jetty.xml.XmlConfiguration.configure(XmlConfiguration.java:310)
        at org.eclipse.jetty.xml.XmlConfiguration$1.run(XmlConfiguration.java:1570)
        at org.eclipse.jetty.xml.XmlConfiguration$1.run(XmlConfiguration.java:1508)
        ... 9 more
Caused by: java.lang.UnsatisfiedLinkError: org.eclipse.jetty.setuid.SetUID.getpwnam(Ljava/lang/String;)Lorg/eclipse/jetty/setuid/Passwd;
        at org.eclipse.jetty.setuid.SetUID.getpwnam(Native Method)
        at org.eclipse.jetty.setuid.SetUIDListener.setUsername(SetUIDListener.java:53)
        ... 27 more

Running `service rudder-jetty supervise` leads to:

2018-05-24 17:36:16.266:INFO::main: Logging initialized @1136ms to org.eclipse.jetty.util.log.StdErrLog
2018-05-24 17:36:16.461:INFO::main: Console stderr/stdout captured to /var/log/rudder/webapp/2018_05_24.jetty.log
Java HotSpot(TM) Server VM warning: You have loaded library /opt/rudder/jetty/lib/setuid/libsetuid-linux.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.

It works as expected with OpenJDK 1.8.0_172.

Happens with rudder 4.3.

#1

Updated by François ARMAND about 2 years ago

  • Status changed from In progress to Rejected

For some reason, the installed java was an i586 package on an x64 server. Using the x64 one made it work.

Also available in: Atom PDF