Project

General

Profile

Bug #15137

Hook Exit code=-2147483648 on one generation (linked to FullGC?)

Added by François ARMAND about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Performance and scalability
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

An user reported an exit code of Int.MIN_VALUE during an especially stressed generation (lots of new groups, generation time much longer than usual...).

Starting again the generation finished flawlessly, and nothing strange with the hook (/opt/rudder/etc/hooks.d/policy-generation-finished/50-reload-policy-file-server, file exists, rights ok, nothing changed for days...).

The exact error is:

[2019-06-27 16:48:32] DEBUG com.normation.rudder.services.policies.PromiseGenerationServiceImpl - Reports updated in 37400 ms
[2019-06-27 16:48:32] DEBUG com.normation.rudder.services.policies.PromiseGenerationServiceImpl - Policy generation completed in 1542141 ms
[2019-06-27 16:48:32] ERROR com.normation.rudder.batch.AsyncDeploymentAgent$DeployerAgent - Error when updating policy, reason *Exit code=-2147483648* for hook: '/opt/rudder/etc/hooks.d/policy-generation-finished/50-reload-policy-file-server'.
stdout:
stderr: ''
[2019-06-27 16:48:32] ERROR com.normation.rudder.batch.AsyncDeploymentAgent - Policy update error for process '35011' at 2019-06-27 16:48:32: Exit code=-2147483648 for hook: '/opt/rudder/etc/hooks.d/policy-generation-finished/50-reload-policy-file-server'.
stdout:
stderr: ''

It seems to correspond to that code in NuProcess: https://github.com/brettwooldridge/NuProcess/blob/nuprocess-1.2.4/src/main/java/com/zaxxer/nuprocess/linux/LinuxProcess.java#L142

What we think may have happened:

- lots of new dyn groups, JVM is stressed
- hooks run
- during hooks, a FullGC happens, something timeout

=> error


Related issues

Is duplicate of Rudder - Bug #15011: Error at the end of a policy generation with too many nodes ReleasedFrançois ARMANDActions
#1

Updated by François ARMAND about 1 year ago

  • Related to Bug #15011: Error at the end of a policy generation with too many nodes added
#2

Updated by François ARMAND about 1 year ago

  • Related to deleted (Bug #15011: Error at the end of a policy generation with too many nodes )
#3

Updated by François ARMAND about 1 year ago

  • Is duplicate of Bug #15011: Error at the end of a policy generation with too many nodes added
#4

Updated by François ARMAND about 1 year ago

Actually, the problem is the same as #15011, so I'm closing that one.

#5

Updated by François ARMAND about 1 year ago

  • Status changed from New to Rejected

Also available in: Atom PDF