Project

General

Profile

Bug #15477

Make rudder-pkg handle confiparser in python 2 and 3

Added by Félix DALLIDET 9 days ago. Updated 9 days ago.

Status:
Pending release
Priority:
N/A
Category:
Relay server or API
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

The lib configparser is from the standard python library but for some reasons on Centos it comes from a package in epel-release.
So we should remove it.

Associated revisions

Revision 4a66c739 (diff)
Added by Félix DALLIDET 9 days ago

Fixes #15477: Make rudder-pkg handle confiparser in python 2 and 3

History

#1

Updated by Félix DALLIDET 9 days ago

  • Subject changed from Remove configparser from rudder-pkg to Make rudder-pkg handle confiparser in python 2 and 3
#2

Updated by Félix DALLIDET 9 days ago

It is in fact available but the module is named ConfigParser in python 2 and has a more restrictive syntax

#3

Updated by Félix DALLIDET 9 days ago

  • Status changed from New to In progress
  • Assignee set to Félix DALLIDET
#4

Updated by Félix DALLIDET 9 days ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Félix DALLIDET to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder/pull/2395
#5

Updated by Félix DALLIDET 9 days ago

  • Status changed from Pending technical review to Pending release

Also available in: Atom PDF