Project

General

Profile

Actions

Bug #16456

closed

error adding allowed network

Added by Fabien C. almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
-
Target version:
-
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Hi,

On a fresh install of rudder 6.0.1 on debian buster, i can't add an allowed network and my agent is refused.
On the server page when i save, i have this message :
'An error occured when trying to get the list of existing allowed networks
Error message was: Unable to save the user event log for modification on authorized networks for policy server root'

The network appears on the webpage, but when i run a debug I see only :
rudder verbose: Host IPs allowed connection access (allowconnects):
rudder verbose: IP: (ip server)
rudder verbose: IP: 127.0.0.1
rudder verbose: IP: ::1
rudder verbose: IP: 127.0.0.0/8

where can i found logs to debug ??

Actions #1

Updated by Fran├žois ARMAND almost 4 years ago

Hello,

We have found a problem with 6.0.1 that leads to PostgreSQL database not being fully configured after installation: password is not correctly set-up (of course leading to connection error). The error message looks like that it may be that (see install note here: https://docs.rudder.io/reference/6.0/installation/install_notes.html)

You could see if the problem is this one by looking at web application logs in /var/log/rudder/webapp/2019_12_22_stderrout.log. You can correct it by running rudder agent in root server, ie as root run: rudder agent run - it can autocorrect after 5 min, since the agent runs periodically.

Actions #2

Updated by Alexis Mousset over 3 years ago

  • Status changed from New to Rejected

Closing for lack of info, please reopen an issue if it happens again.

Actions

Also available in: Atom PDF