Project

General

Profile

Bug #16523

Missing perl-Getopt-Long dependency for fusion on some CentOS8 systems

Added by Alexis MOUSSET 8 months ago. Updated 8 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Packaging
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:
0

Description

[root@template-packer ~]# rudder agent inventory -i
Rudder agent 6.0.1.release
Node uuid: 7a406c3f-6c9b-4b21-aa20-f2d1fb89fc9f
rudder     info: Using command line specified bundlesequence
rudder     info: Executing 'no timeout' ... '/usr/bin/curl -L -k -1 -s -f --proxy '' -o "/var/rudder/cfengine-community/rudder-server-uuid.txt" https://our-server.com/uuid'
rudder     info: Completed execution of '/usr/bin/curl -L -k -1 -s -f --proxy '' -o "/var/rudder/cfengine-community/rudder-server-uuid.txt" https://our-server.com/uuid'
rudder     info: Executing 'no timeout' ... '/opt/rudder/bin/run-inventory --local=/var/rudder/tmp/inventory/template-packer-7a406c3f-6c9b-4b21-aa20-f2d1fb89fc9f.ocs'
   error: Finished command related to promiser '/opt/rudder/bin/run-inventory --local=/var/rudder/tmp/inventory/template-packer-7a406c3f-6c9b-4b21-aa20-f2d1fb89fc9f.ocs' -- an error occurred, returned 2
  notice: Q: "...-inventory --lo": [info] FusionInventory instance: builtin - Perl instance: system
Q: "...-inventory --lo": Can't locate Getopt/Long.pm in @INC (you may need to install the Getopt::Long module) (@INC contains: /opt/rudder/share/fusioninventory/lib /opt/rudder/lib/perl5/x86_64-linux-thread-multi /opt/rudder/lib/perl5 /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /opt/rudder/bin/fusioninventory-agent line 10.
Q: "...-inventory --lo": BEGIN failed--compilation aborted at /opt/rudder/bin/fusioninventory-agent line 10.
rudder     info: Last 3 quoted lines were generated by promiser '/opt/rudder/bin/run-inventory --local=/var/rudder/tmp/inventory/template-packer-7a406c3f-6c9b-4b21-aa20-f2d1fb89fc9f.ocs'
rudder     info: Completed execution of '/opt/rudder/bin/run-inventory --local=/var/rudder/tmp/inventory/template-packer-7a406c3f-6c9b-4b21-aa20-f2d1fb89fc9f.ocs'
Start execution with config [0]

rudder     info: Automatically promoting context scope for 'heartbeat_sent' to namespace visibility, due to persistence
M| State         Technique                 Component                 Key                Message
E| error         Inventory                 inventory                                    Could not execute the inventory
   error: Method 'fusionAgent' failed in some repairs
   error: Method 'doInventory_always' failed in some repairs
info     Rudder agent was run on a subset of policies - not all policies were checked

## Summary #####################################################################
1 components verified in 3 directives
   => 1 components in Enforce mode
      -> 1 error
Execution time: 0.69s
################################################################################

Related issues

Is duplicate of Rudder - Bug #16457: Inventory fails with errors on CentOS/RHEL 8ReleasedBenoƮt PECCATTEActions
#1

Updated by Alexis MOUSSET 8 months ago

  • Status changed from New to Rejected
#2

Updated by Alexis MOUSSET 8 months ago

  • Is duplicate of Bug #16457: Inventory fails with errors on CentOS/RHEL 8 added

Also available in: Atom PDF