Project

General

Profile

Actions

Bug #4949

closed

Ensure that a line is present in a ini section will not work if the section does not exist or is at the end of file but will return a success

Added by Nicolas PERRON over 8 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Priority:
0
Regression:

Description

bundle file_ensure_line_present_in_ini_section() will return success if the section is not present in the file or if the section (and the line) is the last of the file.

The behavior will be that the section is added at the end of the file, but not the line.

A workaround is to use the generic method to add the same section two times, one after the other.

Actions #1

Updated by Alexis Mousset about 6 years ago

  • Category set to Generic methods
Actions #2

Updated by Fran├žois ARMAND over 5 years ago

  • Description updated (diff)
  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority set to 30

This ticket description was in a terrible state, so it needs to be tested again.

Actions #3

Updated by Alexis Mousset over 5 years ago

  • Status changed from New to In progress
  • Assignee set to Alexis Mousset

I will have a look.

Actions #4

Updated by Alexis Mousset over 5 years ago

  • Status changed from In progress to Rejected

I could not reproduce the issue, it has probably been fixed by an stdlib upgrade.

Actions #5

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority changed from 30 to 0
Actions #6

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF