Project

General

Profile

Actions

User story #6369

closed

Run twice the same action

Added by Benoît PECCATTE over 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Generic methods
Target version:
UX impact:
Suggestion strength:
User visibility:
Effort required:
Regression:

Description

Most of ncf methods are state methods, since having a defined state is the goal of a configuration tool, this is desired.

However a few ncf methods are action methods : command_execution and service_restart
We should have a way to force cfengine to run these action every time we ask for it and not once for all, if some technique want to restart twice a service, it should be able to.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #4797: When using multiple times the same generic method on the same object, the reporting will be broken for all of themRejectedActions
Actions #1

Updated by Benoît PECCATTE over 6 years ago

  • Is duplicate of Bug #4797: When using multiple times the same generic method on the same object, the reporting will be broken for all of them added
Actions #2

Updated by Benoît PECCATTE over 6 years ago

  • Status changed from New to Rejected

rejecting as a duplicate

Actions #3

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
Actions #4

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF