Project

General

Profile

Actions

Bug #8846

closed

broken report from Directory check exists

Added by Florian Heigl about 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Hi,

directory check exists should not report an error, it just needs to raise the classes but it shouldn't report an error.
This makes it very very very hard to build policies around "is this mountpoint there, has this program run it's installer..."
Affects easily 20-30% of my techniques.

error etckeeper_install Directory check exists /etc/.git Check if directory /etc/.git exists could not be repaired


Related issues 1 (1 open0 closed)

Is duplicate of Rudder - Architecture #8683: check_* methods output error messages when the result of a check is "no"NewActions
Actions #1

Updated by Alexis Mousset about 6 years ago

  • Category set to Generic methods
  • Target version set to 0.x
Actions #2

Updated by Jonathan CLARKE about 6 years ago

  • Status changed from New to Rejected

Yes, absolutely. This is a duplicate of #8683.

Actions #3

Updated by Jonathan CLARKE about 6 years ago

  • Is duplicate of Architecture #8683: check_* methods output error messages when the result of a check is "no" added
Actions #4

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #5

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions

Also available in: Atom PDF