Project

General

Profile

Bug #12583

Error during postinst on upgrade to 4.3

Added by Benoît PECCATTE 7 months ago. Updated 6 months ago.

Status:
Released
Priority:
N/A
Category:
Packaging
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

When upgrading rudder agent to 4.3 on a debian based system, we get a postinstall error.

Wen run the postinstall script in debug mode (add set -x to /opt/rudder/share/package-scripts/rudder-agent-postinst)
we see that we remove the rudder service whereas the service script is still there.

Moreover the postinst script never finishes and stalls on nohup /opt/rudder/bin/rudder agent check

Associated revisions

Revision d51c2b53 (diff)
Added by Benoît PECCATTE 7 months ago

Fixes #12583: Error during postinst on upgrade to 4.3

History

#1 Updated by Benoît PECCATTE 7 months ago

  • Description updated (diff)

#2 Updated by Benoît PECCATTE 7 months ago

  • Description updated (diff)

#3 Updated by Benoît PECCATTE 7 months ago

  • Status changed from New to In progress
  • Assignee set to Benoît PECCATTE

#4 Updated by Benoît PECCATTE 7 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Benoît PECCATTE to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/1590

#5 Updated by Benoît PECCATTE 7 months ago

  • Status changed from Pending technical review to Pending release

#6 Updated by Vincent MEMBRÉ 6 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 4.3.2 which was released today.

Also available in: Atom PDF