Project

General

Profile

Bug #13703

Missing report when using the "Package state" generic method with default value for the "state" parameter

Added by Félix DALLIDET about 2 months ago. Updated about 1 month ago.

Status:
Released
Priority:
N/A
Category:
Generic methods - Package Management
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

There are default parameters for the fields, an empty "state" parameter will be interpreted as "present".
Though it will generate an incomplete inner_class_prefix resulting in missing reports.

Forcing the execution to a later "pass" in cfegnine should correctly fix this.

Associated revisions

Revision 1bf004b8 (diff)
Added by Félix DALLIDET about 2 months ago

Fixes #13703: Missing report when using the package_state GM with default arg for the \"state\" parameter

History

#1 Updated by Félix DALLIDET about 2 months ago

  • Status changed from New to In progress
  • Assignee set to Félix DALLIDET

#2 Updated by Félix DALLIDET about 2 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Félix DALLIDET to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/ncf/pull/852

#3 Updated by Félix DALLIDET about 2 months ago

  • Status changed from Pending technical review to Pending release

#4 Updated by Alexis MOUSSET about 2 months ago

  • Category set to Generic methods - Package Management

#5 Updated by Vincent MEMBRÉ about 1 month ago

  • Subject changed from Missing report when using the package_state GM with default arg for the "state" parameter to Missing report when using the "Package state" generic method with default arg for the "state" parameter

#6 Updated by Vincent MEMBRÉ about 1 month ago

  • Subject changed from Missing report when using the "Package state" generic method with default arg for the "state" parameter to Missing report when using the "Package state" generic method with default value for the "state" parameter

#7 Updated by Vincent MEMBRÉ about 1 month ago

  • Status changed from Pending release to Released
This bug has been fixed in Rudder 4.3.6 and 5.0.2 which were released today.
Changelog
Changelog

Also available in: Atom PDF