Project

General

Profile

Bug #16010

Dynamic group based on another dynamic group don't work correctly in 6.0

Added by Nicolas CHARLES 22 days ago. Updated 7 days ago.

Status:
Released
Priority:
N/A
Category:
-
Target version:
Severity:
User visibility:
Effort required:
Priority:
0

Description

I have a dynamic group GroupSoftVer98, with definition AND, Operating System Type = Linux, GroupID = GroupIp11
GroupIp11 is a group with only AIX nodes (ans there's no AIX node), so GroupIp11 is empty

As a result, GroupSoftVer98 should be empty, but it contains all nodes

Removing other criteria don't solve the issue, including only this group is still invalid

Associated revisions

Revision 89770108 (diff)
Added by Nicolas CHARLES 20 days ago

Fixes #16010: Dynamic group based on another dynamic group don't work correctly in 6.0

History

#1

Updated by Nicolas CHARLES 22 days ago

  • Subject changed from Dynamic group based on another dynamic group don't work correctly to Dynamic group based on another dynamic group don't work correctly in 6.0
#2

Updated by Nicolas CHARLES 21 days ago

this is totally specific to 6.0, following migration to ZIO
it seems the filter is not applied

#3

Updated by Nicolas CHARLES 20 days ago

  • Status changed from New to In progress
  • Assignee set to Nicolas CHARLES
#4

Updated by Nicolas CHARLES 20 days ago

  • Category deleted (Web - Config management)
  • Target version deleted (6.0.0~beta1)

ok, in 5.0, when computing dnMapMapSets, if resulting set is empty, we exit with an empty result, while in 6.0 it become an empty filter, so doesn't do anything

#5

Updated by Nicolas CHARLES 20 days ago

  • Target version set to 6.0.0~beta1
#6

Updated by Nicolas CHARLES 20 days ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Vincent MEMBRÉ
  • Pull Request set to https://github.com/Normation/rudder/pull/2546
#7

Updated by Nicolas CHARLES 20 days ago

  • Status changed from Pending technical review to Pending release
#8

Updated by Vincent MEMBRÉ 7 days ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 6.0.0~beta1 which was released today.

Also available in: Atom PDF