Project

General

Profile

Bug #16224

Missing documentation on openssl incompatibilities between 4.x and 5.0

Added by François ARMAND 7 months ago. Updated 6 months ago.

Status:
Released
Priority:
N/A
Category:
Documentation
Target version:
Severity:
Critical - prevents main use of Rudder | no workaround | data loss | security
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Very Small
Priority:
104

Description

We had a problem because of a bug where openssl version prior to 1.0.1 were incompatible with version 1.0.2 and up. So when you migrate rudder from 4.X to 5.0, you can have agent <-> server connection failing.

The only solution in that cases are to update agent to a compatible openssl version (ie: use 5.0 agent with embeded ssl) or use relay server built with a specific openssl version compatible with both pre- and post-1.0.1 version.

This need to be documented in upgrade, with a big warning.


Related issues

Related to Rudder - Bug #13690: Impossible to update promises when using a debian9 or Ubuntu 18 server and older distributions as Nodes (incompatible openssl version)ReleasedAlexis MOUSSETActions
#1

Updated by François ARMAND 7 months ago

  • Status changed from New to In progress
#2

Updated by François ARMAND 7 months ago

  • Related to Bug #13690: Impossible to update promises when using a debian9 or Ubuntu 18 server and older distributions as Nodes (incompatible openssl version) added
#3

Updated by François ARMAND 7 months ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from François ARMAND to Alexis MOUSSET
  • Pull Request set to https://github.com/Normation/rudder-doc/pull/644
#4

Updated by François ARMAND 6 months ago

  • Status changed from Pending technical review to Pending release
#7

Updated by Vincent MEMBRÉ 6 months ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 5.0.15 which was released today.

Also available in: Atom PDF