Project

General

Profile

Actions

Bug #16695

closed

file_ensure_key_value_option does not escape well the speciall chars when used with the no_space option

Added by Félix DALLIDET over 4 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
N/A
Assignee:
-
Category:
Generic methods
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
User visibility:
Infrequent - complex configurations | third party integrations
Effort required:
Small
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

Easiest way to reproduce:
Create a key value in a file using the "manage key value in file" technique in rudder, using the no space option.
Key must contains a special char like "_".

It works fine.

Then change the value, re-run the agent and the key is now containing "\_" instead of "_".

Actions #1

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #2

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #3

Updated by Félix DALLIDET about 4 years ago

  • Severity set to Major - prevents use of part of Rudder | no simple workaround
  • User visibility set to Infrequent - complex configurations | third party integrations
  • Effort required set to Small
  • Priority changed from 0 to 53
Actions #4

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #5

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
  • Priority changed from 53 to 51
Actions #6

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
  • Priority changed from 51 to 50
Actions #7

Updated by Benoît PECCATTE about 3 years ago

  • Target version changed from 797 to 6.1.14
  • Priority changed from 50 to 47
Actions #8

Updated by Vincent MEMBRÉ about 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #9

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #10

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #11

Updated by Benoît PECCATTE over 2 years ago

  • Project changed from 41 to Rudder
  • Category changed from Generic methods to Generic methods
Actions #12

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #13

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #14

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #15

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #16

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #17

Updated by Benoît PECCATTE over 1 year ago

  • Status changed from New to Rejected
  • Priority changed from 47 to 0
  • Regression set to No

Cannot reproduce

Actions

Also available in: Atom PDF