Project

General

Profile

Actions

Bug #19257

closed

Result conditions problem after "FileAugeas Set"

Added by Axel Bouet about 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Name check:
To do
Fix check:
To do
Regression:
No

Description

Hello,
I created a technique to change PermitRootLogin from yes to no in the file /etc/ssh/sshd_config.
In this technique, I use the method "File Augeas set" to change the line in the file, then the method "Service Reload" to reload sshd service with the condition any.(file_augeas_setetc_ssh_sshd_config_PermitRootLoginrepaired).

The file is changed, but as the method "File Augeas set", returns "was correct" and not "Repaired".
So the repaired condition is not reached and "Service Reload" is not executed.

Rudder server 6.2.6, node client 6.2.6

Thanks.

[root@esclave03 ~]# grep PermitRootLogin /etc/ssh/sshd_config
PermitRootLogin yes

[root@esclave03 ~]# rudder agent run -i
...
2021-05-11T09:00:03+00:00 Saved 1 file(s)
E| compliant TECH_Config_sshd File Augeas set /etc/ssh/sshd_con| Setting the node value for /etc/ssh/sshdconfig/PermitRootLogin/ was correct
E| n/a TECHConfig_sshd Service reload sshd Skipping method 'Service reload' with key parameter 'sshd' since condition 'any.(file_augeas_setetc_ssh_sshd_config_PermitRootLoginrepaired)' is not reached was not applicable
...

[root@esclave03 ~]# grep PermitRootLogin /etc/ssh/sshd_config
PermitRootLogin no

Actions #1

Updated by Benoît PECCATTE over 2 years ago

  • Category set to Generic methods
  • Target version set to 6.1.19
Actions #2

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.19 to 6.1.20
Actions #3

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.20 to 6.1.21
Actions #4

Updated by Vincent MEMBRÉ about 2 years ago

  • Target version changed from 6.1.21 to old 6.1 issues to relocate
Actions #5

Updated by Benoît PECCATTE over 1 year ago

  • Target version changed from old 6.1 issues to relocate to 7.2.5
  • Regression set to No
Actions #6

Updated by Vincent MEMBRÉ over 1 year ago

  • Target version changed from 7.2.5 to 7.2.6
Actions #7

Updated by Alexis Mousset about 1 year ago

  • Status changed from New to Resolved

This looks like a duplicate of #22677, closing. Please reopen if the problem still exists.

Actions

Also available in: Atom PDF