Project

General

Profile

Actions

Bug #22315

closed

"reportid" missing in PostgreSQL database after upgrade from v6.2.12 to v7.2.3

Added by Lars Koenen over 1 year ago. Updated about 1 year ago.

Status:
Released
Priority:
N/A
Category:
Server components
Target version:
Severity:
Major - prevents use of part of Rudder | no simple workaround
UX impact:
I dislike using that feature
User visibility:
Operational - other Techniques | Rudder settings | Plugins
Effort required:
Priority:
73
Name check:
To do
Fix check:
Checked
Regression:
No

Description

After upgrading the rudder-server from v6.2.12 to v7.2.3, the comliance bar on the nodes remained at 100% gray and the compliance reports tab no longer displayed any status.

The logs in /var/log/rudder/webapp/xxxx_xx_xx.stderrout.log contained many entries like:

ERROR com.normation.rudder.repository.jdbc.ReportsJdbcRepository - Error when trying to find reports by node: ERROR: column "reportid" does not exist
  Position: 52

The logs in /var/log/rudder/install/rudder-server-xxxxxxxxx.log contained:

Techniques have been updated, and update branch set to current state of the Techniques
INFO: Upgrading PostgreSQL DB............ FAILED
PostgreSQL service verification failed after 10 tries.
 ERROR
INFO: Upgrading LDAP DB............ FAILED
LDAP service verification failed after 10 tries.
 ERROR
Plugins were not updated, because connection test is failing, please upgrade your plugins manually

ERROR: The migration has failed in some steps. Check previous error messages.
Please restart the failed service(s), and start the migration script again.
(try service rudder-server restart)
Once it is working, run:
# /opt/rudder/bin/rudder-upgrade
INFO: Correcting permissions on /var/rudder/configuration-repository... Done
Running plugins upgrade scripts
Restoring file ACLs
FINISH: Rudder agent check ran properly, please look at messages above to see if there has been any error.

Running /opt/rudder/bin/rudder-upgrade again, like in #21705, fixed the problems.

Actions #1

Updated by Vincent MEMBRÉ over 1 year ago

Thanks for reporting your issue.

Did you upgrade finished well ? rudder-upgrade should have been ran during upgrade from 6.2 to 7.2. do you have the logs from your upgrade ? Also we may be interesed by the logs in /var/log/rudder/install/ (i guess rudder-server log file )

Actions #2

Updated by Alexis Mousset over 1 year ago

  • Status changed from New to Rejected

closing as it did not have answers, please reopen if the problem persists

Actions #3

Updated by Nicolas CHARLES about 1 year ago

  • Status changed from Rejected to New
  • Target version changed from 7.2.5 to 7.2.6
  • Priority changed from 76 to 74

the problem still exists
database is sometimes shut down when running rudder-upgrade. As a workaround, we can ensure it is started

Actions #4

Updated by Nicolas CHARLES about 1 year ago

  • Status changed from New to In progress
  • Assignee set to Nicolas CHARLES
Actions #5

Updated by Nicolas CHARLES about 1 year ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Nicolas CHARLES to Alexis Mousset
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/2712
Actions #6

Updated by Nicolas CHARLES about 1 year ago

  • Status changed from Pending technical review to Pending release
Actions #7

Updated by Vincent MEMBRÉ about 1 year ago

  • Priority changed from 74 to 73
  • Fix check changed from To do to Checked
Actions #8

Updated by Vincent MEMBRÉ about 1 year ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 7.2.6 and 7.3.1 which were released today.

Actions

Also available in: Atom PDF