Project

General

Profile

Architecture #2312

Rename PT/PI/CR in packaging

Added by Jonathan CLARKE about 9 years ago. Updated almost 9 years ago.

Status:
Released
Priority:
1
Category:
Architecture - Refactoring
Target version:
Pull Request:
Effort required:

Description

See #2295 for the full description. This issue is a sub-task for the packaging part, on the master branch.

List of affected packages:
  • rudder-policy-templates: needs to be renamed, and use different paths
  • rudder-webapp: postinst and rudder-upgrade script
  • rudder-server-root: copy initial promises
  • rudder-agent: copy initial promises
Other things to change:
  • Name of the rudder-policy-templates GitHub repo (rudder-techniques)
  • Packaging in version 2.3 for this repo name change
  • Normation's internal automatic merge script
  • Script that builds a source tarball
  • Change our CI server to use the new names and package names
  • rudder-init.sh script: change LDIF for "policyInstanceVariable"

Related issues

Related to Rudder - User story #2295: BREAKING CHANGE: Rename Policy Template, Policy Instance and Configuration RulesReleasedFrançois ARMAND2012-02-17Actions
Related to Rudder - Bug #2758: Can't upgrade from 2.3 to 2.4 with apt-getReleasedNicolas PERRON2012-08-02Actions
Related to Rudder - Architecture #7723: Remove deprecated package rudder-policy-templatesReleasedBenoît PECCATTE2016-01-04Actions
#1

Updated by Jonathan CLARKE about 9 years ago

  • Status changed from In progress to Pending technical review
  • % Done changed from 0 to 100

Applied in changeset commit:658ef7966abdcc5872e046da21425d8fa47b8dd6.

#2

Updated by Matthieu CERDA almost 9 years ago

This looks fine, and it seems we do not have any "legacy" entry left that break Rudder. This bug may be closed.

#3

Updated by Jonathan CLARKE almost 9 years ago

  • Tracker changed from User story to Architecture
  • Status changed from Pending technical review to Released
#4

Updated by Jonathan CLARKE over 5 years ago

  • Related to Bug #2758: Can't upgrade from 2.3 to 2.4 with apt-get added
#5

Updated by Jonathan CLARKE over 5 years ago

Also available in: Atom PDF