Project

General

Profile

Actions

User story #3371

closed

APT package manager should manage GPG keys for added repos

Added by Dennis Cabooter about 11 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
2
Assignee:
-
Category:
Techniques
UX impact:
Suggestion strength:
User visibility:
Effort required:
Name check:
Fix check:
Regression:

Description

We use an Ubuntu PPA (additional repository) to install the latest git. I need to download/import a GPG key to make this actually work - the package manager will complain otherwise and Rudder fails to install git. Is it possible to implement this into the "APT package manager configuration" technique or is there another way to do this?

Kind regards


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #6756: New Technique to import a GPG Key into RPMReleasedNicolas CHARLES2016-02-29Actions
Actions #1

Updated by Jonathan CLARKE about 11 years ago

  • Tracker changed from Question to User story
  • Project changed from Rudder to 24
  • Subject changed from APT package manager configuration GPG keys to APT package manager should manage GPG keys for added repos
  • Category set to Techniques
  • Status changed from New to 8
  • Assignee set to Nicolas PERRON
  • Priority changed from N/A to 2

Dennis Cabooter wrote:

We use an Ubuntu PPA (additional repository) to install the latest git. I need to download/import a GPG key to make this actually work - the package manager will complain otherwise and Rudder fails to install git. Is it possible to implement this into the "APT package manager configuration" technique or is there another way to do this?

Absolutely. We have a similar feature for zypper (SuSE package manager), we can easily adapt it for apt*.

Actions #2

Updated by Dennis Cabooter about 11 years ago

That would be very nice to add. :)

Actions #3

Updated by Benoît PECCATTE over 9 years ago

  • Project changed from 24 to Rudder
  • Category changed from Techniques to Techniques
Actions #4

Updated by Benoît PECCATTE about 9 years ago

  • Status changed from 8 to New
Actions #5

Updated by Benoît PECCATTE about 9 years ago

  • Assignee deleted (Nicolas PERRON)
  • Target version set to Ideas (not version specific)
Actions #6

Updated by Alexis Mousset about 8 years ago

  • Is duplicate of User story #6756: New Technique to import a GPG Key into RPM added
Actions #7

Updated by Alexis Mousset about 8 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF