Project

General

Profile

Actions

Bug #3964

closed

Packages on Red Hat get status repaired for $CHECK_INTERVAL minutes with technique version 5.0

Added by Dennis Cabooter over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
2
Assignee:
Matthieu CERDA
Category:
Techniques
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Name check:
Fix check:
Regression:

Description

Packages on Red Hat get status repaired for $CHECK_INTERVAL minutes with technique version 5.0. However, most of them were installed and some not.

What I did:

- Migrated back to technique version 4.1
- Executed cf-agent -KI

All statuses are now Success and the missing packages were installed. However, having to set $CHECK_INTERVAL for every single package makes the technique looks a bit messy.


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #4145: Technique 'Package management for RHEL / CentOS / SuSE / RPM systems' v4.0, 4.1 and 5.0: Incorrect clear of cache of installed packaged on promises updates lead to have 'No answer' states after a modification of packages in DirectiveReleasedJonathan CLARKE2013-11-11Actions
Actions #1

Updated by Vincent MEMBRÉ over 10 years ago

  • Assignee set to Matthieu CERDA
  • Priority changed from N/A to 2

I think this behavior may be expected. The last action was a repaired state,

after the end of check_interval, thenext execution should be with a suscess state.

Matthieu can you look into this ?

Actions #2

Updated by Dennis Cabooter over 10 years ago

The statuses are not right, 2 of the packages were not installed at all and had status repaired, which was not true.

Actions #3

Updated by Vincent MEMBRÉ over 10 years ago

Ok the repaired is weird for those two packages.

I suspect that an error happend with yum with those two (git and etckeeper ?) but cfengine analyse this result as a repaired.

Actions #4

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.6 to 2.4.10
Actions #5

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.4.10 to 2.6.7
Actions #6

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.7 to 2.6.8
Actions #7

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.8 to 2.6.9
Actions #8

Updated by Nicolas PERRON over 10 years ago

  • Target version changed from 2.6.9 to 2.6.10

It seems related to #4145

Actions #9

Updated by Vincent MEMBRÉ over 10 years ago

  • Target version changed from 2.6.10 to 2.6.11
Actions #10

Updated by Nicolas CHARLES over 10 years ago

Hi Dennis,

This looks a lot like a duplicate of 4145, which has been fixed. I'm closing this ticket then

thank you, and feel free to reopen it if the problem still exists

Actions #11

Updated by Nicolas CHARLES over 10 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF