Project

General

Profile

Bug #4032

There is a typo in Rudder file disclaimer

Added by Dennis Cabooter over 6 years ago. Updated over 6 years ago.

Status:
Released
Priority:
4
Category:
System techniques
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

A few things about the Rudder disclaimer:

- Not all the files managed by Rudder have a disclaimer
- In /etc/ssh/sshd_config the disclaimer is printed twice and upside down

root@node:~# head -14 /etc/ssh/sshd_config
#############################################################
### This file is protected by your Rudder infrastructure. ###
### Manually editing the file might lead your Rudder      ###
### infrastructure to change back the server?s            ###
### configuration and/or to raise a compliance alert.     ###
#############################################################

#############################################################
### configuration and/or to raise a compliance alert.     ###
### infrastructure to change back the server?s            ###
### Manually editing the file might lead your Rudder      ###
### This file is protected by your Rudder infrastructure. ###
#############################################################

Related issues

Is duplicate of Rudder - Bug #2247: Warning is inserted upside down in config filesRejected2012-02-07Actions
#1

Updated by Dennis Cabooter over 6 years ago

Also "server?s" should be "server's".

#2

Updated by Jonathan CLARKE over 6 years ago

  • Status changed from New to Rejected
  • Target version set to 2.4.12

Thanks for the report Dennis. This was already reported in #2247, so closing this as a duplicate, and adding you as a follower over there.

See also #3720 that would help with this (making it a one-liner) - what is your opinion about that ticket? Could you let us know by a comment over there?

#3

Updated by Jonathan CLARKE over 6 years ago

  • Subject changed from Rudder disclaimer in files twice and upside down to Rudder disclaimer has a typo on "server?s" (should be "server's")
  • Category set to System techniques
  • Status changed from Rejected to In progress
  • Assignee set to Jonathan CLARKE
  • Priority changed from N/A to 4

Oops, I missed this:

Also "server?s" should be "server's".

Re-opening, but targeting for just that issue.

#4

Updated by Jonathan CLARKE over 6 years ago

  • Status changed from In progress to Pending technical review
  • Assignee changed from Jonathan CLARKE to Nicolas CHARLES
  • Pull Request set to https://github.com/Normation/rudder-techniques/pull/214
#5

Updated by Jonathan CLARKE over 6 years ago

  • Status changed from Pending technical review to Pending release
  • % Done changed from 0 to 100

Applied in changeset policy-templates:commit:74c5df79fcb74b1545c537d7f856cbb70ab3981f.

#6

Updated by Nicolas CHARLES over 6 years ago

Applied in changeset policy-templates:commit:24a974f10e597f9e600464657fcab709be30924f.

#7

Updated by Vincent MEMBRÉ over 6 years ago

  • Subject changed from Rudder disclaimer has a typo on "server?s" (should be "server's") to There is a typo in Rudder file disclaimer
#8

Updated by Nicolas PERRON over 6 years ago

  • Status changed from Pending release to Released

This bug has been fixed in Rudder 2.4.12 which was released today.
Check out:

#9

Updated by Alex Tkachenko over 6 years ago

The same issue is present in v 2.8.1

Also available in: Atom PDF