Project

General

Profile

Actions

Bug #5280

closed

When the ldap tree changes, Rudder can't always access new info after an update

Added by Nicolas CHARLES about 8 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
2
Category:
System integration
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

Upgrading to 2.10 to 2.11, on a Centos6.5, cause the server not to have any roles
Regenerating inventories don't solve the issue, the inventory has the role, but it doesn't show up in the webapp

Reindexing the slapd fixes the issue


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - Bug #6199: When migrating from 2.10 to 2.11, if BDB need to be upgraded, all changes made by rudder-upgrade are revertedReleasedNicolas CHARLES2015-01-29Actions
Actions #1

Updated by Nicolas PERRON about 8 years ago

  • Target version changed from 2.11.1 to 2.11.2
Actions #2

Updated by Nicolas CHARLES about 8 years ago

  • Assignee set to Matthieu CERDA

Running /etc/init.d/rudder-slapd reindex solves the issue

Actions #3

Updated by Matthieu CERDA about 8 years ago

  • Status changed from New to Discussion
  • Assignee changed from Matthieu CERDA to Nicolas CHARLES
  • Priority changed from N/A to 2
Hmmmm, I am unable to reproduce this on a CentOS 6 machine:
  • Installed Rudder 2.10.3
  • Upgraded to Rudder 2.11.1
    => Roles are not here yet (Role: Rudder root server)
  • Forced an inventory (cf-agent -KI -Dforce_inventory)
    => Roles are all right now: "Role: Rudder server (rudder-webapp, rudder-inventory-ldap, rudder-jetty, rudder-ldap, rudder-reports, rudder-inventory-endpoint, rudder-db, rudder-server-root)"

This looks fine to me, maybe it can be related to a machine specific issue ?

Actions #4

Updated by Nicolas PERRON about 8 years ago

  • Target version changed from 2.11.2 to 2.11.3
Actions #5

Updated by Matthieu CERDA about 8 years ago

  • Target version changed from 2.11.3 to 2.11.4
Actions #6

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.4 to 2.11.5
Actions #7

Updated by Vincent MEMBRÉ almost 8 years ago

  • Target version changed from 2.11.5 to 2.11.6
Actions #8

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.6 to 2.11.7
Actions #9

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.7 to 2.11.8
Actions #10

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.8 to 2.11.9
Actions #11

Updated by Vincent MEMBRÉ over 7 years ago

  • Target version changed from 2.11.9 to 2.11.10
Actions #12

Updated by Nicolas CHARLES over 7 years ago

  • Status changed from Discussion to Rejected
  • Reproduced set to No

I'm rejecting this issue as a duplicate of #6199

Actions

Also available in: Atom PDF