Project

General

Profile

Bug #5439

Upgrade from 2.10.x to 2.10.5 can prevent promises generation

Added by Nicolas CHARLES almost 6 years ago. Updated over 4 years ago.

Status:
Released
Priority:
N/A
Category:
System integration
Target version:
Pull Request:
Severity:
User visibility:
Effort required:
Priority:

Description

When we upgrade from 2.10.x to 2.10.5 using the standard procedure, we are in a state where promise generation is impossible.

We introduced new generic methods in ncf that are not compatible with Rudder 2.10, and we also included a script ( see http://www.rudder-project.org/redmine/issues/5402 ) to load only the relevant Techniques.
However the promises that already exist on the Policy Server don't use yet this script, so they cannot avoid loading the bad generic methods.

The specific upgrade procedure would be:

With Debian like system:

apt-get install rudder-server-root
/etc/init.d/rudder-jetty restart
# Wait for the Web Interface to be fully started
# Click on Update on the top right hand side corner, to trigger promises regeneration
apt-get install ncf

With RPM based system

yum update "rudder-*" 
/etc/init.d/rudder-jetty restart
# Wait for the Web Interface to be fully started
# Click on Update on the top right hand side corner, to trigger promises regeneration
yum update ncf

If you updated both rudder-server-root and ncf at the same time, and are stuck, you can resolv the issue by running the command

cp /opt/rudder/share/tools/list-compatible-inputs  /var/rudder/tools/

and there regenerate promises (in the Web Interface, click on "Update" on the top right hand side corner)


Related issues

Related to Rudder - Bug #5402: Agent can't run because some ncf promises are CFEngine 3.6 specificReleased2014-08-19Jonathan CLARKEActions
#1

Updated by Nicolas CHARLES almost 6 years ago

  • Description updated (diff)
#2

Updated by Nicolas CHARLES almost 6 years ago

  • Status changed from New to Pending technical review
  • Pull Request set to https://github.com/Normation/rudder-packages/pull/468
#3

Updated by Nicolas CHARLES almost 6 years ago

  • Assignee changed from Nicolas CHARLES to Jonathan CLARKE
#4

Updated by Nicolas CHARLES almost 6 years ago

  • Status changed from Pending technical review to Rejected

The solution in the PR is not relevant anymore, we now always rely on the ncf version of list-compatible-inputs

#5

Updated by Matthieu CERDA almost 6 years ago

  • Status changed from Rejected to Released

This bug has been fixed in Rudder 2.10.6, which was released today.
Check out:

#6

Updated by Matthieu CERDA almost 6 years ago

This bug has been fixed in Rudder 2.10.6, which was released today.
Check out:

#7

Updated by Benoît PECCATTE over 4 years ago

  • Pull Request deleted (https://github.com/Normation/rudder-packages/pull/468)

Also available in: Atom PDF