Project

General

Profile

Actions

Bug #6281

closed

? escaped in in the path variable parameter of ncf-builder URL

Added by Vincent MEMBRÉ over 7 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
3
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

Sometimes '?' are rewritten "%3F" in ncf-builder, preventing parsing of path parameter.

Actions #1

Updated by Vincent MEMBRÉ over 7 years ago

  • Description updated (diff)
  • Status changed from New to Pending technical review
  • Assignee changed from Vincent MEMBRÉ to François ARMAND
  • Pull Request set to https://github.com/Normation/ncf/pull/172
Actions #2

Updated by François ARMAND over 7 years ago

  • Subject changed from rewrite wrong url preventing access to path variable to ? escaped in in the path variable parameter of ncf-builder URL
  • Description updated (diff)
  • Status changed from Pending technical review to Rejected

So,

The problem seems to only appears when we try to use "#?!xxxxx" kind of parameter for an (old) version of ncf-builder that is expecting only "?xxxx". Something with angularjs, but we didn't find quite excatly what.

And in fact, we don't care, because for old version of ncf-builder, we don't want to have unescaped "?" in the fragment part of the url.

So rejecting it, with "oh, the computer are doing the right stuff, sorry digital master lords"

Actions #3

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #4

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF