Project

General

Profile

Actions

Bug #7237

closed

no pid check in rudder-agent init script

Added by Francois BAYART about 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
N/A
Category:
Agent
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
Regression:

Description

I have the crazy idea to run every often "service rudder-agent start", so I'm testing this to be sure it's possible and the result seems to be not.

service rudder-agent start && service rudder-agent start && ps fax

=>
28066 ? Ss 0:00 /var/rudder/cfengine-community/bin/cf-serverd
29955 ? Ss 0:00 /var/rudder/cfengine-community/bin/cf-execd
30342 ? Ss 0:00 /var/rudder/cfengine-community/bin/cf-execd

the cf-execd PID is present ( /var/rudder/cfengine-community/cf-execd.pid ) with the value of the last started process.

In the source code (line 188) https://github.com/Normation/rudder-packages/blob/master/rudder-agent/SOURCES/rudder-agent.init#L188 the seems missed just a comment "# Presence of PID file"

After few minutes the cf-execd processes are all killed.

Actions #1

Updated by Vincent MEMBRÉ about 7 years ago

  • Assignee set to Benoît PECCATTE
  • Target version set to 2.10.18

François, what would be the expected behavior ?

Matthieu, benoit, what should be done here ?

I assign 2.10 version since we should check if it is ok there before

Actions #2

Updated by Francois BAYART about 7 years ago

Vincent MEMBRÉ wrote:

François, what would be the expected behavior ?

start nothing if the process is started.

https://gist.github.com/frbayart/4e1bf257690ba2298460

Actions #3

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 2.10.18 to 2.10.19
Actions #4

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 2.10.19 to 2.10.20
Actions #5

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 2.10.20 to 277
Actions #6

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 277 to 2.11.18
Actions #7

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.11.18 to 2.11.19
Actions #8

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.11.19 to 2.11.20
Actions #9

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.11.20 to 2.11.21
Actions #10

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.11.21 to 2.11.22
Actions #11

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 2.11.22 to 2.11.23
Actions #12

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.11.23 to 2.11.24
Actions #13

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 2.11.24 to 308
Actions #14

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 308 to 3.1.14
Actions #15

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 3.1.14 to 3.1.15
Actions #16

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 3.1.15 to 3.1.16
Actions #17

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 3.1.16 to 3.1.17
Actions #18

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 3.1.17 to 3.1.18
Actions #19

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 3.1.18 to 3.1.19
Actions #20

Updated by Benoît PECCATTE over 5 years ago

  • Status changed from New to Rejected

This seems to be fixed now.
Feel free to reopen if not.

Actions

Also available in: Atom PDF