Project

General

Profile

Actions

Bug #8023

closed

command_exection_result defaulting to 'error' state is not documented

Added by Florian Heigl over 6 years ago. Updated 4 months ago.

Status:
Rejected
Priority:
N/A
Category:
Generic methods
Target version:
Severity:
UX impact:
User visibility:
Effort required:
Priority:
0
Regression:

Description

This class can define a repair and a kept outcome.
It cannot define an error.

This is kind of, umm, problematic.

I have failing commands that are interpreted as happy commands.

(If possible, make it so that one is able to configure it so that any unexpected state means an error.
Doesn't need to be default, but that was the one big PITA from start with the normal scheduler.

We use script wrappers for this now.)


Related issues 1 (0 open1 closed)

Is duplicate of Rudder - User story #7879: Add documentation for ncf generic methodsReleasedBenoît PECCATTEActions
Actions #1

Updated by Benoît PECCATTE over 6 years ago

I will assume that you didn't mean scheduler here, but just command_exection_result

There is no error state in the command_exection_result genric method since any state not in success or repaired is considered as an error.
The acceptance test for this methods says it is the case.

Do you want tro have e default other than error or have I just missed something that happen to be your case ?

Actions #2

Updated by Florian Heigl over 6 years ago

Hi,

then it should be all as I wanted it. I could not see the text saying it's defaulting to error. might be fine print ;)

I'll re-test tomorrow and close if it was just PBKAC

Actions #3

Updated by Florian Heigl over 6 years ago

Ah, yeah its really just in the method documentation. Not obvious for mr. clickyclicky ;-)

Actions #4

Updated by Benoît PECCATTE over 6 years ago

  • Subject changed from Scheduler command_exection_result is missing 'error' state to command_exection_result defaulting to 'error' state is not documented
  • Target version set to 0.x

Sorry, changing the subject to patch documentation then

Actions #5

Updated by Alexis Mousset over 6 years ago

  • Status changed from New to In progress
  • Assignee set to Alexis Mousset
Actions #6

Updated by Alexis Mousset over 6 years ago

  • Status changed from In progress to Rejected

Handled in #7879. Closing this one.

Actions #7

Updated by Alexis Mousset over 6 years ago

  • Is duplicate of User story #7879: Add documentation for ncf generic methods added
Actions #8

Updated by Alexis Mousset 4 months ago

  • Target version changed from 0.x to ncf-0.x
  • Priority set to 0
Actions #9

Updated by Alexis Mousset 4 months ago

  • Project changed from 41 to Rudder
  • Category set to Generic methods
Actions

Also available in: Atom PDF