Project

General

Profile

Actions

Bug #9127

closed

User story #8563: Make the quicksearch bar in menu able to also search rule, group, directive, etc

Quicksearch bar is broken in 3.2

Added by François ARMAND over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
1
Category:
Web - UI & UX
Target version:
Severity:
User visibility:
Effort required:
Priority:

Description

After merging things from 3.1 to 3.2, the quicksearch bar is broken.
The first error is a lift "no class def found", which can be workaround with changing the following line in common-layout.html:

<lift:QuickSearchNode.render>

By;
<div data-lift="QuickSearchNode.render">

But afterward, I'm hitting a "angular modole can not be load:

Failed to instantiate module quicksearch due to:
[$injector:modulerr] http://errors.angularjs.org/1.2.25/$injector/modulerr?p0=...
D/<@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:6:450
e/<@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:34:97
r@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:7:288
e@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:33:207
e/<@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:33:284
r@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:7:288
e@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:33:207
gc@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:36:309
fc/c@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:18:170
fc@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:18:387
Xc@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:17:415
@http://localhost:8082/rudder-web/javascript/angular/angular.min.js:214:469
v.Callbacks/l@http://localhost:8082/rudder-web/javascript/jquery/jquery-1.8.3.min.js:2:16991
v.Callbacks/c.fireWith@http://localhost:8082/rudder-web/javascript/jquery/jquery-1.8.3.min.js:2:17783
.ready@http://localhost:8082/rudder-web/javascript/jquery/jquery-1.8.3.min.js:2:12502
A@http://localhost:8082/rudder-web/javascript/jquery/jquery-1.8.3.min.js:2:9907

I fear it is due to some inconsistency between version.


Related issues

Is duplicate of Rudder - Bug #9150: Repair quicksearch in 3.2ReleasedFrançois ARMAND2016-09-27Actions
Actions #1

Updated by Vincent MEMBRÉ over 4 years ago

  • Status changed from New to Rejected

Sorry, did'nt see that issue, opened it and fixed it #9150

Actions #2

Updated by Vincent MEMBRÉ over 4 years ago

  • Is duplicate of Bug #9150: Repair quicksearch in 3.2 added
Actions

Also available in: Atom PDF