Project

General

Profile

User story #9836

Updated by Fran├žois ARMAND over 2 years ago

API v5 (resp v6) is linked to Rudder 3.0 (resp 3.1). It can be deprecated in Rudder 4.1 because with a new would-be LTS, we deprecate API up-to previous LTS.

We can should also deprecate v7 because it is version n-2 and all API version are deprecated up to that version.

We can also
completly remove api v2, v3, and v4 because the are pre-3.1, so before previous LTS, so not supported anymore.

This ticket is only about no more exposing the rudder/api/2,3,4/... version. Of course, endpoints added
anymore (maybe it should go in these version are still accessible throught higher version number or latest. an other ticket).

Back