Project

General

Profile

Actions

Bug #11277

closed

Bad documentation about roles may lead to upgrade failing

Added by I C almost 7 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
N/A
Assignee:
-
Category:
Documentation
Target version:
Severity:
Minor - inconvenience | misleading | easy workaround
UX impact:
User visibility:
Operational - other Techniques | Technique editor | Rudder settings
Effort required:
Small
Priority:
0
Name check:
Fix check:
Regression:

Description

Hi,

I have an error when upgrading my rudder server from 4.1.3 to 4.1.6 on post upgrade script (/opt/rudder/bin/rudder-upgrade), here is an extract :
INFO: Checking PostgreSQL service status............ FAILED
PostgreSQL service verification failed after 10 tries.
INFO: Checking LDAP service status............ FAILED
LDAP service verification failed after 10 tries.

I have four servers and results depend on values in this file /var/rudder/cfengine-community/inputs/rudder-server-roles.conf.

For exemple one server with this content in /var/rudder/cfengine-community/inputs/rudder-server-roles.conf :
rudder-ldap:rudder-srv01
rudder-inventory-endpoint:rudder-srv01
rudder-db:pg-serv
rudder-relay-top:rudder-srv01
rudder-web:rudder-srv01

Upgrade script will fail when testing ldap and db access :
INFO: Launching script to check if a migration is needed
INFO: Checking if rudder-web.properties database access credentials are all right... LDAP OK, SQL OK
INFO: Checking if inventory-web.properties database access credentials are all right... LDAP OK, SQL skipped
INFO: A Technique library reload is needed and has been scheduled.
INFO: The /var/rudder/configuration-repository/techniques/ncf_techniques/category.xml file already exists. Not updating.
INFO: Alternative source path added: /var/rudder/configuration-repository/ncf
INFO: Checking PostgreSQL service status... OK
INFO: Checking LDAP service status............ FAILED
LDAP service verification failed after 10 tries.

Here is an extract of /opt/rudder/etc/rudder-web.properties :
ldap.host=localhost
rudder.server-roles.ldap=rudder-srv01

The problem is that upgrade script check role from this file /var/rudder/cfengine-community/inputs/rudder-server-roles.conf and this content override value of LDAP_SERVER variable at runtime.

Changing rudder.server-roles.ldap=rudder-srv01 to rudder.server-roles.ldap=autodetect does not change the result.

Excecuting /opt/rudder/bin/rudder-upgrade before and after upgrade result into the same problem.

LDAP service is bind on localhost and the upgrade script try to connect throught server hostname resolution (server ip) which is not possible.

When temporarily changing value of rudder-ldap:rudder-srv01 to rudder-ldap:localhost from /var/rudder/cfengine-community/inputs/rudder-server-roles.conf result to a working upgrade script.

I have a external DB.
I have one server with a bad value on rudder-db:rudder-srv01 instead of rudder-db:pg-serv in /var/rudder/cfengine-community/inputs/rudder-server-roles.conf and upgrade script also fails on database check.

I don't have /opt/rudder//etc/server-roles.d/rudder-server-root file

DNS resolution works.

Ldap service was not modify by hand.

If you want i can give you more information about this issue.

Thanks

Actions #1

Updated by I C almost 7 years ago

It seems the problem is older than this upgrade.

My /opt/rudder/etc/rudder-web.properties was not well configured on all my nodes.

Changing rudder.server-roles.ldap to rudder.server-roles.ldap=localhost, restarting the webapp and trigerring a policy generation as effect to update /var/rudder/cfengine-community/inputs/rudder-server-roles.conf and /opt/rudder/bin/rudder-upgrade execution works after all this steps.

Problem comes from my side.

Actions #2

Updated by François ARMAND almost 7 years ago

  • Subject changed from Update script failed after upgrading from 4.1.3 to 4.1.6 to Bad documentation about roles may lead to upgrade failing
  • Category changed from Packaging to Documentation
  • Target version set to 3.1.23
  • Severity set to Minor - inconvenience | misleading | easy workaround
  • User visibility set to Operational - other Techniques | Technique editor | Rudder settings
  • Priority changed from 0 to 32

Thanks for the feedback.
I'm requalifying that one to a documentation problem.

Actions #4

Updated by Vincent MEMBRÉ almost 7 years ago

  • Target version changed from 3.1.23 to 3.1.24
Actions #5

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.24 to 3.1.25
Actions #6

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 3.1.25 to 387
  • Priority changed from 32 to 31
Actions #7

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 387 to 4.1.10
Actions #8

Updated by Vincent MEMBRÉ over 6 years ago

  • Target version changed from 4.1.10 to 4.1.11
  • Priority changed from 31 to 30
Actions #9

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.11 to 4.1.12
  • Priority changed from 30 to 29
Actions #10

Updated by Vincent MEMBRÉ about 6 years ago

  • Target version changed from 4.1.12 to 4.1.13
  • Priority changed from 29 to 28
Actions #11

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 4.1.13 to 411
Actions #12

Updated by Benoît PECCATTE about 6 years ago

  • Target version changed from 411 to 4.1.13
Actions #13

Updated by Vincent MEMBRÉ almost 6 years ago

  • Target version changed from 4.1.13 to 4.1.14
Actions #14

Updated by Benoît PECCATTE almost 6 years ago

  • Target version changed from 4.1.14 to 4.1.15
  • Priority changed from 28 to 27
Actions #15

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.15 to 4.1.16
Actions #16

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.16 to 4.1.17
Actions #17

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.17 to 4.1.18
  • Priority changed from 27 to 0
Actions #18

Updated by Vincent MEMBRÉ over 5 years ago

  • Target version changed from 4.1.18 to 4.1.19
Actions #19

Updated by Alexis Mousset over 5 years ago

  • Target version changed from 4.1.19 to 4.1.20
Actions #20

Updated by François ARMAND over 5 years ago

  • Target version changed from 4.1.20 to 4.1.21
Actions #21

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.21 to 4.1.22
Actions #22

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.22 to 4.1.23
Actions #23

Updated by Vincent MEMBRÉ about 5 years ago

  • Target version changed from 4.1.23 to 4.1.24
Actions #24

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 4.1.24 to 588
Actions #25

Updated by Alexis Mousset almost 5 years ago

  • Target version changed from 588 to 5.0.13
Actions #26

Updated by Vincent MEMBRÉ almost 5 years ago

  • Target version changed from 5.0.13 to 5.0.14
Actions #27

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.14 to 5.0.15
Actions #28

Updated by Benoît PECCATTE over 4 years ago

  • Effort required set to Small
Actions #29

Updated by Vincent MEMBRÉ over 4 years ago

  • Target version changed from 5.0.15 to 5.0.16
Actions #30

Updated by Alexis Mousset over 4 years ago

  • Target version changed from 5.0.16 to 5.0.17
Actions #31

Updated by Vincent MEMBRÉ about 4 years ago

  • Target version changed from 5.0.17 to 5.0.18
Actions #32

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.18 to 5.0.19
Actions #33

Updated by Vincent MEMBRÉ almost 4 years ago

  • Target version changed from 5.0.19 to 5.0.20
Actions #34

Updated by Vincent MEMBRÉ over 3 years ago

  • Target version changed from 5.0.20 to 797
Actions #35

Updated by Benoît PECCATTE almost 3 years ago

  • Target version changed from 797 to 6.1.14
Actions #36

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.14 to 6.1.15
Actions #37

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.15 to 6.1.16
Actions #38

Updated by Vincent MEMBRÉ almost 3 years ago

  • Target version changed from 6.1.16 to 6.1.17
Actions #39

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.17 to 6.1.18
Actions #40

Updated by Vincent MEMBRÉ over 2 years ago

  • Target version changed from 6.1.18 to 6.1.19
Actions #41

Updated by François ARMAND over 2 years ago

  • Status changed from New to Resolved

Role are removed in 7.0 and won't lead to more strange behavior.

Actions

Also available in: Atom PDF